Sign in with
Sign up | Sign in
Your question

No SLI after running "Driver Cleaner Pro"

Last response: in Graphics & Displays
Share
August 23, 2010 11:50:18 AM

Hello,
I was having some bad graphics bug where after every reboot I would have to reinstall the drivers, but then I found a program called "Driver Cleaner Pro" and used that to fix my issue.

so now my graphics run ok but now I do not have the SLI option on my Nvidia Control Panel where it usually is. It only shows the Physx options now.

I have attempted to reinstall the latest driver (Nvidia 258.96) and even installed the previous driver (Nvidia 191.07) but neither have seemed to bring back my SLI.

I tried various searches have checked the device manager and the cards are recognized. I also ran GPU-z and they were discovered too. I also checked both cards that they were producing images when plugged into a monitor.

The only thing I can think of at the moment is maybe I have a bad SLI Bridge? Would I need to replace that to get it noticed again? Help would be most appreciative.
a c 168 Î Nvidia
August 23, 2010 12:03:53 PM

You could try removing one of the cards to see if that resets anything but this is one of the reasons I don't like those driver cleaner programs as they sometimes remove things they shouldn't.
August 23, 2010 1:02:04 PM

agreed. is there other options if takin the card out doesnt work? also would reinstalling windows 7 fix my sli issue? id wanna save that as a last resort
Related resources
a c 168 Î Nvidia
August 23, 2010 1:07:06 PM

A format and reinstall would reset everything but I would just try deleting all the Nvidia files from the system32 folder first.
August 23, 2010 4:39:38 PM

so jus delete the entire nvidia folder and reinstall the drivers? alrighty ill try it out when i get back
a b Î Nvidia
August 23, 2010 4:53:40 PM

Unless Driver Sweeper Pro changed a BIOS setting (disabling SLI), you continue to have a driver issue is my guess. So mousemonkey's suggestion to remove the existing nVidia files is a good idea.

Personally, I like to use Driver Sweeper from Guru3D to do the cleanup if I'm using a utility.

http://www.guru3d.com/category/driversweeper/

You might also want to make sure that Driver Sweeper did not remove any essential drivers for your motherboard chipset.
August 23, 2010 8:26:17 PM

i assumed it mightve been the case wirh my chipset, so installed the drivers again a well as update my mobo bios. still no avail. i will try the driver sweeper too
August 24, 2010 3:50:40 AM

Alright well none of those suggestions worked. I ended up just doing a clean install of windows 7 & I still get no SLI option. I'm completely out of ideas now. Any other possible suggestions?
a b Î Nvidia
August 24, 2010 6:08:39 AM

If you've completely formatted and reinstalled, there must be a hardware problem someplace.

However, you said you updated your mobo bios. I'm assuming you mean you Flashed it to the newest BIOS version? If so, doing such sets all the BIOS settings to "Default". You might want to make sure something in the BIOS was changed. Some boards you can enable/disable SLI ability.
!