Sign in with
Sign up | Sign in
Your question
Solved

Simultaneous analog and optical output needed

Last response: in Components
Share
January 3, 2011 9:29:50 PM

I've got a Harmon Kardon AVR-635 receiver at the center of my entertainment setup. It's a decent receiver with a few quirks I have had to work around. In the past I have had to connect my Logitech Squeezebox up to both a digital and analog input because the multi room feature of the receiver only takes analog input.

So I'd connect the digital out to the main room speakers and the analog to the multi room feed, which goes to the kitchen speakers. That worked well but now my Squeezebox has died. I could just buy another Squeezebox (although it's harder to find the "Classic" without a touchscreen these days), but then I thought I'd try just using my htpc for music and save the money.

The htpc runs Win7 x64 with 4GB ram and a AMD dual core 2.5 GHz low power processor. I run mostly WMC with a little Boxee and Hulu here and there. The onboard audio has digital and analog outputs, but only one (digital OR analog) seems to be active at a time. I need digital for the decoding for movies, so I just need an additional analog output. I tried one of those cheap USB sound cards to add an analog output and it gets recognized by Windows, but the output never seem to be active and it's grayed out in the Windows mixer.

Is there a way I can get audio to both the digital and analog outputs at once? It seems like it doesn't need to be this complicated, but apparently it is. Any hits or ideas would be appreciated!

Thanks!
-Matt

Best solution

January 4, 2011 11:50:14 AM

The only way for a PC to output from two different audio outputs at the same time is if the program you are using supports selecting a sound device other then whatever is set to the windows default.

EG: You can have the default set to analog, and have a program (say, Windows Media player) set to digital. This way, everything would output via analog, except WMP, which would output via digital.

If you need to output using a SINGLE program, the only chance you have would be if it allows you to open multiple copies of itself AND it allows you to select a non-default device. You *might* be able to get one instance of the program outputting using a different device then the other one...

Also, I note, most PC media players have the ability to nativly decode most audio formats, so you can pass through via analog instead of carrying the encoded audio to a receiver via digial. That sounds like a simpler (and more practical) solution for you...
Share
January 14, 2011 3:11:42 AM

Best answer selected by mattb.
m
0
l
Related resources
January 14, 2011 3:12:31 AM

Thanks. I ended up getting a different receiver without that stupid restriction and problem solved! :) 
m
0
l
January 16, 2011 2:49:05 PM

mattb said:
Thanks. I ended up getting a different receiver without that stupid restriction and problem solved! :) 


I have the same problem with a new Onkyo receiver. I gotta ask, what receiver did you find without the zone2/multiroom analog only input quirk?
m
0
l
January 17, 2011 1:30:22 PM

Well I wasn't really using the multiroom feature like I had planned when I originally bought it, I was basically using it as A/B speakers. I just got a Pioneer VSX-920-K and I'm just using the A/B speakers like I probably should have from the start. Seems like a nice receiver and the hdmi switching/upscaling is very handy. I eliminated a bunch of cables and an addition hdmi switch. The entertainment center is much tidier now.
m
0
l
April 5, 2013 10:03:07 AM

I have never tried this, but I have a similar problem, I want to output to my headphones and speakers at the same time. Also apparently you could do this in Windows Xp, but Microsoft removed this in later versions of windows. My solution: Make your higher-quality source the default, then get a hub of some sort for that output, probably 10-15$ online, then get an adapter to what other source you use, and hook the other source up to the adapter, probably 5-10$ online, and hook up the other source to the adapter, and because it hooks up to the higher quality output, any loss in quality won't be very noticeable, then hook those up to their corresponding places. I'm not sure if this works, but please try it and reply. The other option would be to download/create a third party program, but don’t use Virtual Audio Cable, because I have heard it doesn’t work. I hope this works.
m
0
l
January 8, 2014 9:03:22 PM

archimedes_15 said:
mattb said:
Thanks. I ended up getting a different receiver without that stupid restriction and problem solved! :) 


I have the same problem with a new Onkyo receiver. I gotta ask, what receiver did you find without the zone2/multiroom analog only input quirk?


I know this an old post but heres a fix that worked for me and i have an Onkyo receiver with zone 2 analog input only. I have HDMI audio output to Onkyo for A/V playback of streamed movies but also have rear analog speaker output to onkyo analog input on receiver. I can send same audio signal to main speakers and to zone 2 speakers on back porch. you may have play with these steps a little bit depending on your configuration, mine didnt only say "speakers", it gave me the option of "TX-SR806" which is my onkyo, along with "Speakers" option, so you may to choose that instead. Good luck

RealTek soundcard users

For users with a RealTek soundcard, follow the steps below:
Windows 7 (english)
FIRST:
Open Control Panel
Click "Sound"
Click the "Playback" Tab
Right-click "Realtek Digital Output" and click "Set as Default Device" (if the option is not available, it is already default)
THEN:
Click the "Recording" Tab
Right-click "Stereo Mix" and Click "Enable" (if disabled)
Right-click "Stereo Mix" again and click "Set as Default Device"
Right-click "Stereo Mix" yet again and click "Properties"
Click the "Listen" tab
Check "Listen to this device"
Under "Playback through this device:" select "Speakers"
Click OK to close Stereo Mix Properties.
Click OK to close Sound Devices
So to be clear, the Default Playback Device must be "Realtek Digital Output" (digital) and the Default Recording Device must be "Stereo Mix" 'listening' to: "Speakers." If you set it the other way around you will not be able to enjoy any multi-channel audio as everything will be downmixed to 2.0 audio.
m
0
l
January 25, 2014 11:54:26 PM

Awesome post, this solved the problem for me,I can now use the built in optical and analog outs simultaneously on my PC's built in soundcard. The only thing is I had to do it in reverse--"Speakers"is the default playback device, and Digital Out is my "listen to" under Stereo Mix. Since I only use my PC to play Spotify and iTunes through my Harmon Kardon receiver, being limited to 2 channel stereo isn't a problem for me. All I want to do is feed music to my living room and a set of kitchen speakers.

Oddly, if I set it up the way you mentioned, with digital as the default and "speakers" set in the Stereo Mix, the PC would send system sounds to my kitchen speaker but not any music. I would get music playing in the living room and only system beeps in the kitchen.
m
0
l
January 26, 2014 11:32:50 AM

toecheese said:
Awesome post, this solved the problem for me,I can now use the built in optical and analog outs simultaneously on my PC's built in soundcard. The only thing is I had to do it in reverse--"Speakers"is the default playback device, and Digital Out is my "listen to" under Stereo Mix. Since I only use my PC to play Spotify and iTunes through my Harmon Kardon receiver, being limited to 2 channel stereo isn't a problem for me. All I want to do is feed music to my living room and a set of kitchen speakers.

Oddly, if I set it up the way you mentioned, with digital as the default and "speakers" set in the Stereo Mix, the PC would send system sounds to my kitchen speaker but not any music. I would get music playing in the living room and only system beeps in the kitchen.


m
0
l
January 26, 2014 11:40:03 AM

@ toecheese, Glad it worked for you.. Like I said in my post, "you may have to play around with these steps depending on your configuration". I guess I should have said, you may have to play around with these steps depending if you care about hearing system sounds, haha There has to be a way of disabling system sounds, I would have to test if this is possible or not but if your happy with your setup, it's all good :-)
m
0
l
!