Can't boot from bootable USB stick

Hello, I have built an XP PC using an ASUS motherboard M4N68T-M LE V2 with AMI BIOS.
It all works OK except that I can't boot from USB sticks. I have several sticks, from different manufactures, each containing a different LINUX distro. They all boot OK from my older PC which also has an ASUS motherboard and AMI BIOS.

I have been in contact with ASUS for about 3 weeks, I have followed all their instructions, but I still have my problem. I am thinking of buying ASUS motherboard M4A88TD-V EVO/USB3 in the hope that it may solve my problem. ASUS tell me that this, in theory, should boot from a stick, but they said that about the other one and it doesn't. So I am not interested in theory now, I need a practical positive report.

I should be most grateful if anyone could tell me that they have practical experience of the
ASUS M4A88TD-V EVO/USB3 booting perfectly from a bootable USB stick.

Kind regards, Vincent Kingston
11 answers Last reply
More about boot bootable stick
  1. go to bios then select the usb as your first boot to load the Operating system....
  2. I tried that , it does not work.

    I am going to remove the ASUS MOBO and fit an ASRock MOBO that I am assured will boot my stick.

    Kind regards Vincent.
  3. The solution is pretty simple.

    The usb must be supported by the motherboard.
    So, maybe you can ask Asus for a list of supported usb sticks.

    One usb might work on one motherboard, but not on the other.
    I learned this from my own experiences.
  4. I have a Linux system running on a ASUS M4A88TD-V EVO/USB3
    The boot order in the BIOS is set DVD, "Removable Device", [first HDD]

    It will sometimes boot from a USB stick but it doesn't boot consistently from a USB. The only way I have found to boot reasonably reliably from USB sticks is to press F8 when the green ASUS splash screen appears and keep it held down until the boot choice menu appears. Pressing F8 /before/ the splash screen appears seems to foul things up. I normally turn off the manufacturer's splash screen but with this mobo it's easier to see what's happening with it enabled.

    In the light of this experience, I cannot assure the OP that this board would boot reliably from a USB stick. All the sticks I use boot reliably on the Gigabyte based systems I have. I'll need some convincing to use an ASUS board again.
  5. This is actually very common -
    Some best practices for flash USB booting devices are.

    1) Format USB stick with either FAT 16 or FAT32, NTFS is not supported.
    2) Some SDHC USB sticks with removeable flash cards are incompatable for boot.
    They are not recognized at boot due to memory scheme interleave which requires the operating system to be connected first to the device to work.
    3) First boot device set to "removable storage" in Bios.
    4) Use Flash memory rated below a class 9. Bios chips are usually slow speed devices.
    5) Make sure the USB setting in the bios has legacy USB support enabled. (USB power-on at boot).
    6) Add a delay to the boot for some Linux builds as this sometimes can help with the proper load order.

    Always use a dedicated USB stick of 2Gb or less as sometimes (depends on Bios) the Bios cannot read a stick of any larger capacity.

    Also be sure to use the "active USB port" of your Mobo. Usually identified as the 2 rear ports near or below the LAN connection. See your Mobo owners manual for these.
    Many Mobos only have 2 USB ports which are active at boot time. The others are only active after the OpSys USB root hub loads.

    :hello:
  6. Hi,
    I had this boot problem on an Asus x53s. The solution is very simple ! 
    Good explanations are here : http://nongeekrecipes.org/2011/03/04/i-have-an-asus-eee-pc-and-i-cant-boot-from-a-bootable-usb-key-what-should-i-do/#comment-339

    I tell it from memory. In the bios (press F2), in the boot menu, we all see the «change boot order priority» option. If you tried to change the order here, you may have wondered what to write in the field ±«path to usb». I read in some forums we have to look for a .efi file. But no need to do this. Actually, do not configure this part.
    Under that menu there is one called approximatively «disk order priority» : this is HERE we have to choose the usb first.
    Quit and save your bios settings.
    That worked for me.
    I then installed LinuxMint 13 in dual boot with windows 7 without any problems, everything works super fine.

    Hope this helps, it was hell of an option to find !
  7. 100% solution to this problem!

    1) Turn off your PC
    2) Plug in USB bootable device
    3) Go to BIOS
    4) Set Boot device priority to 1st removable
    5) Open option "Hard Disk Drives" and set Removable to be the 1st and HDD 2nd drive
    This work only if USB is pluged in before PC start UP and BIOS can see yours USB. Now when I have no Flash drive in, bios show only HDD as 1st and no option to change.
    6) Save and exit BIOS
  8. thread is over a year old
  9. Can you please be more specific?
    i have been trying to find a way to set usb as a first boot to load in the bios but no luck so far.
    Thanks!

    marbski said:
    go to bios then select the usb as your first boot to load the Operating system....
  10. Pallew you are amazing, I know this is many years old thread, but I been messing around for months but I finally got your help.

    My mainboard is very old and you have made my day. Thank you!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  11. I know people alrdy gave this up, but in case someone struggles again with this

    Resetting to default settings in the bios, and setting the intel controller to enhanced made my USB sticks boot up again
    what caused it i dont know and it probably cost me my other pc s life
Ask a new question

Read More

Asus Boot Motherboards