Sign in with
Sign up | Sign in
Your question
Solved

Games crashing with 16gb RAM

Last response: in Memory
Share
August 31, 2011 9:13:51 PM

Hi all,

I am troubleshooting a small issue with my new(ish) system. Specs:

Phenom II 1090t BE
MSI 890fxa-gd65
MSI Twin Frozr III 6950
Corsair 750w PSU
Crucial M4 SSD
16gb G. Skill 1600 memory (the problem)

So. When I first put the system together, I used an 8gb G. Skill set, and didn't have a single error or problem anywhere in my use of the computer. I mainly use it for gaming (Fallout 3, Borderlands, etc.). A month after I got the computer, I saw another set of the same RAM go on sale, so I grabbed it. Once I put the RAM in, I began to get a couple bluescreens here and there, and games crashing to the desktop.

So, I intended to get a replacement set of RAM from G. Skill. Before I did that, a friend mentioned that sometimes AMD mobos/BIOS settings need to be tweaked slightly to work well with 16gb RAM. Do you guys happen to know if this exists, or if I still just need to replace my RAM?

Basically, any tips to get my computer to like my RAM would be nice :) 

Thanks guys!
a b } Memory
September 1, 2011 12:07:39 AM

When you added the two extra memory modules you increased the memory bus load and may need to relax a BIOS memory setting.

Run CPU-Z.

Click on the Memory tab page.

Look in the Timings group box for the Command Rate (CR) value. If the value reported is 1T you will need to make a BIOS memory setting change as follows:

CMOS Setup Utility --> Cell Menu --> Advance DRAM Configuration
...
1T/2T Memory Timing [Auto], [1T], [2T] controls the SDRAM command rate.
...

Change this setting from [Auto] or [1T] to [2T], save this change and reboot.

Try your applications and see if you have regained stability.
m
0
l
September 1, 2011 12:30:29 AM

You probably need to upgrade the BIOS. A lot of Motherboards are running BIOS instructions that were in place before 4 GB Modules hit the market. I had some issues when I bumped my Rig to 16 GB but after upgrading the BIOS to the latest version the problems seemed to have gone away.
m
0
l
Related resources
September 1, 2011 12:36:54 AM

Dont you think the first thing this guy should do is test the other set with memtest86??

If you know its the ram that you added being the culprit wouldnt you start by seeing if the ram is even any good?

Once you verify you even have good ram, then you can worry about all the timing crap.
m
0
l
September 1, 2011 12:48:10 AM

Unfortunately while running Memtest can be useful the test will probably pass as the RAM is "good" but it is its ability to interface with the motherboard that is compromised by the motherboard BIOS. However it would not hurt to run Memtest. People need to factor in that 16 GB kits are only just starting to appear and that teething issues with such configurations exist .
m
0
l
September 1, 2011 1:04:18 AM

Well you gotta start somewhere and tearing through your bios is not gonna get you anywhere if the other kit is bad. And its not a 16g kit its a 2x4 and people need to understand thats why the kits cost a little more because they are tested to work together.

He should be testing the added ram 1 stick at a time to eliminate that being a problem.
m
0
l
September 1, 2011 1:14:28 AM

I don't see where he states he is running a 2x4. He states he was running 8 GB before jumping to 16 GB but not the literal configuration. Assuming that it is a 16 GB kit he has now that kit is likely 4x4. Many Boards claim to run 16 GB but require BIOS upgrades to do so. This is even specified by various suppliers when they state that their board will support 16 GB but will require updating when the chips that make that possible come on the market. 4 GB Dimms are new. You cant properly support something that did not exist when your board was released.
m
0
l
a c 347 } Memory
September 1, 2011 2:41:12 AM

If running DDR3 1600 on AMD then raise the FSB -> 240 MHz and modify the CPU Multiplier.

1090T BE
3200MHz / 200 MHz = 16
3200MHz / 240 MHz = 13.3 ; depending on your menu 240MHz * 14 = 3360 MHz = 3.36GHz

BIOS:
FSB -> 240MHz
CPU Multiplier -> 13 or 14 ; 13 is under-clocking CPU and 14 is a +0.16GHz
DRAM Frequency -> DDR3-1600
DRAM Voltage -> {spec} ~ {spec + 0.05v}
DRAM Timings -> {spec} (CAS-TRCD-TRP-TRAS-CMD) ; yes use Command Rate -> 2
CPU NB VID Voltage -> 1.20v~1.30v ; {1.2 for 1.5v RAM/1.30 for 1.6~1.65v RAM} don't confuse chipset NB Voltage this is the CPU's IMC
Save & Exit = Yes

Test with Memtest86+ or Prime95 blend test.
m
0
l
September 2, 2011 12:04:26 AM

Well thanks for all the tips guys. I still don't think the system is working right with the RAM.

I gave the bios update a try today, from v18.1 to v18.3. That caused more issues than I've had on this computer. My computer kept switching in and out of IDE and AHCI modes, updates were failing, etc. At one point my computer said there was no bootable disc. So, I'm going to stick with v18.1 because it seems slightly more stable.

I tried switching the 1T/2T Memory Timing, but unfortunately it still wasn't very stable.

I forgot to mention this in my original post: I'm only running the RAM at 1333Mhz. I just haven't gotten around to overclocking to the RAM's rated speeds. Is there a chance doing so would solve my problem?

Again, thanks for the help. Keep the tips coming :) 
m
0
l
a c 347 } Memory
September 2, 2011 12:43:21 AM

Q - What Matched Set of 4x4GB did you buy, please provide a link to the kit.

If you have ANY OC Apps or ANY BIOS invasive Apps then uninstall them; they 100% conflict manual changes to the BIOS. The Command Rate helps, but only at rated speeds i.e. DDR3 1600. The bigger issue is the 16GB and the burden to the CPU, so IF you won't set the RAM correctly then at minimum do the following;

Full Defaults and:
DRAM Voltage -> 1.50v ~ 1.55v
CPU NB VID Voltage -> 1.20v ~ 1.25v

the reason for the variance, like vCore, there are variances.

Next AHCI, both the BIOS AND OS must be set correctly. Use 'Fix It' or set the Start = 0 = AHCI <OR> Start = 3 = IDE; See -> http://support.microsoft.com/kb/922976 and verify See -> http://i1013.photobucket.com/albums/af254/Jaquith/AHCI_...

Once you've got it working, then maybe set it rated as above. Until then IF it works test w/Memtest at least 4-passes -> http://www.memtest.org/
m
0
l
September 3, 2011 12:23:33 AM

It wasn't a matched 4x4 set, but two matched 4x2 sets (http://www.newegg.com/Product/Product.aspx?Item=N82E168...)

I tried the steps you've suggested, and there is still a slight stability problem. At this point I think I'll get a replacement RAM set, and try to update the BIOS at a later date.

How can I tell what speed the RAM is currently at? I do not recall making any changes to the RAM speed, but in BIOS the Adjusted DRAM Frequency says 1600mhz. Does RAM speed matter in my problem?

Thanks guys!
m
0
l
September 3, 2011 12:45:20 AM

You should try updating the BIOS before worrying about returning the RAM. I had a stability issue when I jumped my i7 to 16 GB RAM and it went away when I updated the BIOS.
m
0
l
a c 347 } Memory
September 3, 2011 12:58:58 AM

'Define' the stability problem...look at the Event Manager and the Critical errors listed. Don't assume it the RAM. Yes, I agree with the BIOS update - now.

To verify 1600 MHz, it will show-up as DRAM Frequency = 800MHz {I/O bus clock}; CPU-z -> http://www.cpuid.com/softwares/cpu-z.html

This is an example of DDR3 1066 (533 * 2):


Event Manager:
m
0
l
September 3, 2011 2:13:06 AM

By stability problem I mean my games are still crashing off and on. Probably once every few hours of play. Actually no critical errors appear in the Event Manager, but I know some factor related to the RAM is at fault for my problems.

I just haven't had any luck updating the BIOS, which is why I'm hesitant to do so. Every time I try updating, the computer hangs up after going through the update process for at least a half hour. So, when I have to restart and change back to AHCI mode, I get a disc read error.



I guess my RAM is already at 1600mhz.
m
0
l

Best solution

a c 347 } Memory
September 3, 2011 2:59:12 AM

RogueHermit said:
I just haven't had any luck updating the BIOS, which is why I'm hesitant to do so. Every time I try updating, the computer hangs up after going through the update process for at least a half hour. So, when I have to restart and change back to AHCI mode, I get a disc read error.

BIOS settings is an ALL or NONE; you either set all the settings as I've stated or run the RAM at DDR3 1333MHz.

Well you clearly haven't set the RAM manually, it's rated for 1600 9-9-9-24-2N. Maybe give it a try?! On AMD you are ASKING for trouble running DDR3 1600 unless you: 1. FSB 240MHz+ <OR> 2. CPU-NB Frequency to 2400MHz (DDR3 1600 / 2 = 800MHz, then x 3)

If you have ANY OC Apps or ANY BIOS invasive Apps then uninstall them!!!!!

Don't use -> BIOS Code Unlocked Technology, MSI Control Center, or MSI Live Update 5. If the BIOS continues to act up then Clear CMOS -> http://www.youtube.com/watch?v=rdHH9KrceR0 <OR> update the BIOS!

Run MSCONFIG -> select Diagnostic <OR> Services tab select Hide MS services and uncheck all the other junk, Startup uncheck everything listed and reboot - TEST.

The HD 6900 series runs hot, run 3DMark 11 if DirectX 11 is installed or 3DMark Vantage if only using 10 -> http://www.futuremark.com/ and watch all of the temps; use HW Monitor -> http://www.cpuid.com/softwares/hwmonitor.html


BIOS
FSB -> 240MHz
CPU Multiplier -> 14
DRAM Frequency -> DDR3-1600
DRAM Voltage -> 1.55v~1.60v
DRAM Timings -> 9-9-9-24 (CAS-TRCD-TRP-TRAS)
Command Rate -> 2
CPU NB VID Voltage -> 1.20v~1.25v ; don't confuse chipset NB Voltage this is the CPU's IMC
Save & Exit = Yes

---

BIOS
DRAM Frequency -> DDR3-1600 = GUARANTEED by itself to FAIL!!!
Share
September 3, 2011 6:59:30 AM

Alright, I just made the changes you suggested. I'll be out of town for a few days, so I won't exactly be able to test it until I'm back. If I have any other problems, I'll report back. Until then, thanks a bunch for your help!
m
0
l
September 12, 2011 7:05:51 AM

Okay, after using the computer for a few days with those changes, it's been fine! Looks like I'm good to go now!

Thanks for the help guys! Jaquith, thanks for the really informative and detailed posts :)  best answer for you!
m
0
l
September 12, 2011 7:06:14 AM

Best answer selected by RogueHermit.
m
0
l
!