East West composers edition 1tb hard drive

Hello all,

I am trying to use the 1tb hard drive supplied by east west and my mac book pro says every single time I turn it on "the disk you inserted was not readable by this computer" if someone could help me rectify this problem id appreciate it! the drive is defo for mac as there is a mac sticker on the composers box, thanks!.
21 answers Last reply
More about east west composers edition hard drive
  1. You have to go into your Disk Utility and initialize the drive (partition and set up a file system).
  2. Thanks for replying, ok so im on disk utility and ive clicked on the 1tb hard drive, do i click on the partition tab? when I do it gives me a volume scheme drop down and there are up to 16 partitions available for selection?.
  3. Just use 1 partition.
  4. It says that adding a partition will delete all data on the disk?? :/.
  5. Yep. Do you have anything stored on the disk already?
  6. Yes the 1tb hard drive comes with several programs loaded on it.
  7. Yep!
  8. Check this link:

    http://download.soundsonline.com/docs/PLAY-2-FAQ.pdf

    Or try this:
    I’m getting an error during installation on a Mac. What should I do?
    If permissions are set to READ ONLY on a particular folder that the installer needs to write to, nothing can be installed to that folder and the install will fail. Make sure folder permissions are set to READ & WRITE. Here’s how to do that:
    1. Control-Click (or) Right-Click on the folder.
    2. Go to “Get Info” in the menu.
    3. Click on the triangle to the right of Sharing & Permissions.
    4. Click on the padlock and enter the user name/password.
    5. Ensure all privileges are set to Read & Write.
    6. In the lower-left, just to the right off the +/- signs, click on the gear icon and choose to “apply to all enclosed items.”
    Some common folders on which to check this are:
    • Mac HD > Applications > East West
    • Mac HD > Library > Application Support >Digidesign
    • Mac HD > Library > Application Support >Digidesign>Plugins
  9. Hmm near the bottom of the 1tb hard drive tab that im currently clicke don it says, "write status: read and write" yet that post suggest set this to read and write? confused :/
  10. The 1tb hard drive isnt even being recognised in the finder window so i cant click on any folders?
  11. Have you ever been able to access the drive on any system?
  12. The drive only came today tbh :/.
  13. And no I havent tried it on any other system because my mac pro is the only system with a daw to support plug ins like east west.
  14. Try accessing with another system to see if it is readable. As I understand the product, any Mac (current ones any way) should be able to access the drive. It is possible that the product is defective (not ready to make that call).

    I would assume a PC could access it as well.
  15. Also, have you looked at this support site for the product?

    http://www.soundsonline.com/Support/Mac-Installation-PLAY
  16. Ive tried using the hard drive on an Imac and I still get the same message mhmmm the drive should be formatted for a mac because i remember selecting that option and there was a sticker on the drive itself saying its for a mac but i dont know perhaps there has been a mix up...

    Defective is starting to look more likely...im currently emailing the company but the replies from them are very slow.
  17. Try on any Windows PC you have access to as well.

    I assume you are connecting via USB, correct?
  18. Unfortunately I dont have access to a Windows PC.

    Yeah the sata drive is in Dynamode hard disk enclosure which uses a USB.
  19. Did you try another USB cable?

    Also, in your Disk Utility, there is a "fix/repair" option. I am not where I can look at my MacBook Pro to assist further, but did you look or try that with the HDD?
  20. Hi,

    Did you manage to figure out how to get it to work? i am suffering from the exact same issue. if you did please share.

    Thank you
Ask a new question

Read More

Hard Drives Macintosh Storage