Sign in with
Sign up | Sign in
Your question
Closed

WD My Passport not recognized by usb 3.0

Tags:
  • Hard Drives
  • Western Digital
  • USB
  • External Hard Drive
  • Storage
Last response: in Storage
Share
January 17, 2013 1:47:49 AM

Okay, this is an odd problem that I can't seem to fix. I will be extremely grateful if someone knows a fix.

I have a Sony Vaio Laptop (f series) that has 2 usb 3.0 drives. I bought a Western Digital My Passport 1tb external hard drive that is 3.0/2.0 compatible. When I plug in the usb, the external hard drives light turns on and I can feel it spinning. No autorun comes up and it is not visible in my computer. I have uninstalled and reinstalled the usb hub drivers with no fix. I have triple checked to make sure the usb drivers are the most up to date. I have also been to WD's website and have the external hard drives drivers properly installed.

The external hard drive works on my other computer that has usb 2.0.

Here is the odd part. I bought a usb 2.0 hub that i plug into my laptop so i can use more than 2 usb devices at a time. When I plug my usb 2.0 hub into the computer and my external hard drive into the usb hub, the computer CAN SEE the external hard drive. So I can access the external hard drive on my laptop, but i bought this external hard drive because it has usb 3.0 capabilities and using the hub reduces the speed to 2.0 speed.

Any ideas of what the problem is? Thanks for any help!

More about : passport recognized usb

January 17, 2013 5:55:30 AM

Do you have another USB3 cable you can try? It sounds like the USB 3 parts of the cable might not be working.
Score
0
January 17, 2013 7:35:59 PM

My external hard drive works on other computers with usb 3.0 ports. It just doesn't work on my laptop's usb 3.0 ports unless I use the usb 2.0 hub.
Score
0
Related resources
January 17, 2013 7:41:20 PM

Have you checked your bios to see if there is a usb3 setting in there? I know I can enable/disable usb3 speeds for my laptop for power saving or some such reason.
Score
0
January 17, 2013 8:10:19 PM

Yes, I did check that. While the computer was booting I hit f3 (I think it was f3) and it took me to the cmos. I looked around and didn't see any options that included usb3. Honestly, it had very few options compared to other machines I've been in.
Score
0
January 30, 2013 1:53:05 PM

Okay, so I've come to the conclusion that the external hard drive is just not getting enough power to run at the usb 3.0 speeds. I've done a bunch of crap with my drivers, talked to sony support and tried their fix (as discussed in this forum post http://www.tomshardware.com/forum/67141-63-please-help-... ), and still no luck. Like I've said, my external hard drive works on other usb 3.0 computers.

Is there a way to send more power to the usb controller? I checked my computers bios at boot and didn't see the option, but maybe I'm just looking in the wrong place. Or maybe there is a safe 3rd party software that would enable this.

Any suggestions? Any help is greatly appreciated.
Score
0
February 6, 2013 6:26:48 PM

Anyone..?
Score
0
a c 155 G Storage
February 8, 2013 3:16:23 AM

Did the drive come with a "Y" adapter with two USB plugs on one end (1 USB 3.0 and 1 USB 2.0) and a USB 3.0 plug on the other end? Is the drive powered by the USB bus or does it have a power adapter so the drive is self-powered?
Score
0
May 19, 2013 8:40:11 PM

reposting from another thread started in 2011 i just updated, got confused and posted there instead of here

Id this problem, the usb3 external drive wouldnt show up when plugged into the usb3 ports, but still showed up in the usb2 ports, yet any usb2 devices still worked in the usb3 ports

Turned out the problem was my startup routine wasnt loading all the drivers and services (was stuck on 'Selective startup' in the msconfig/General tab). However trying to change it back to 'Normal startup' would crash msconfig, so restarted windows in safe mode but in safe mode after unticking 'Safe boot' (in msconfig/Boot) so itd restart normally next time, the Startup selection in the msconfig/General had changed back to 'Normal startup' on its own, so just had to restart the system and the change carried over.

Iow bit of a strange glitch and work around considering i didnt need to change anything, just launch in safe mode then restart the system normally

the systems a HP dv6 laptop with Win7 64bit, the external drives a WD My Book 3.0
Score
0
!