Sign in with
Sign up | Sign in
Your question

Ahci not working

Last response: in Motherboards
Share
September 2, 2011 3:33:46 AM

i have an asus crosshair 2 formula motherboard, i have been running this with AHCI enabled since it pulled it from the box. the other day i restarted the computer due to slow performance and it wouldnt recognize any of the sata drives. it said insirt system disk and press enter. i went into bios and checked, there were NO drives listed. during boot process it goes through the ahci chipset process and it lists all that are connected to it as it flashes for about 2 seconds but in bios nothing. I have switched to ide mode and the computer booted up just fine but crashed. i ended up doing a repair in ide mode but now it wants to reformat all my of my drives (no way dude im not loosing all my 6 TB of stuff) any help would be great on getting this motherboard to recognize the drives? oh and i have a SATA blu ray DVD drive that it also doesnt recognize so i cant reinstall or fix anything in AHCI mode till thats fixed.

More about : ahci working

a b V Motherboard
September 2, 2011 4:52:34 AM

You cannot switch SATA modes (AHCI to IDE, or IDE to AHCI) after Windows installation without a Windows Registry fix. That's why you crashed when you switched to IDE mode.

Disconnect all of your drives except the system drive, clear the cmos on your motherboard, change the SATA mode of your system drive to AHCI, and see if you can boot into Windows.

If you're able to get into Windows download the latest AMD AHCI drivers from this link: http://support.amd.com/us/gpudownload/windows/Pages/rai...

After you've installed the drivers, reboot, then shut down, connect your other drives, change their SATA mode to AHCI.

After that, double-check that your system drive is 1st in boot order before booting into Windows.

m
0
l
September 2, 2011 9:21:40 AM

i might have not made it clear, its vista and doesnt need drivers, already factory installed with vista. i fully understand the reason i had to "repair" as bios would not see any drive in ahci. ill reset the CMOS and see if that will allow the motherboard bios to see the drives. i do know there is 2 AHCI only slots you're supposed to plug atapi and sata hdd into for the initial install, and i did make sure those were in the correct spot. ill post if the CMOS reset works or not.
m
0
l
Related resources
a b V Motherboard
September 2, 2011 11:59:46 AM

The OS still installs and deals with the HDDs based on IDE or AHCI mode. It does include a built in driver for each, but you can't switch them without changing the registry to let it know that it will be dealing with the HDD in a different way.

The suggested solution is a good start. Clear the CMOS, boot into the BIOS, change back to AHCI and try to boot to your system drive.
m
0
l
September 18, 2011 5:14:06 AM

complete BIOS and CMOS reset, changed bios setting to ahci and booted computer. where the AHCI chip first gets power it actually sees the atapi device and also HDD. when motherboard is completely booted all i get is "disk boot failure, please insert system disk and hit any key" the bios are set to boot from atapi first then hdd. i have vista disk in drive and it doesnt see either drive at all. im at a complete loss as to what could be the issue. im going to continue to poke around the bios and see if i can really screw stuff up, maybe ill get lucky.
m
0
l
a b V Motherboard
September 19, 2011 3:14:16 PM

Poking around in the BIOS shouldn't be able to really screw something up...remember, you can always clear the CMOS and set back to defaults.

Have you tried with just one disk? How about the most minimal configuration possible? Just the HDD...one stick of RAM, onboard video or only one graphics card? Change it from booting from ATAPI to booting the HDD first.

Have you tested something like that yet?
m
0
l
September 26, 2011 1:59:54 AM

yes i even tried just booting to a memory stick in a USB port and i can not get anywhere. it will not recognize anything plugged into motherboard, but the ahci chip its self will see all devices. its like the ahci chip isnt being allowed to operate after the board first starts up. i tested ram and am only running one vid card. i did take it out and try onboard video but it was still no luck... im at a loss. my last ditch effort was to pull battery and unplug it over night... no luck still. i think the time to take this to the shooting range is coming close. i have an older motherboard that has ahci on it, but just dont wanna go back to a 1ghz 2 core processor. that would be real torture.
m
0
l
!