SSD Problem

I just got an Intel 330 180gb SSD and ever since I have installed it, it has been causing intermittent hanging and freezing. This only happens when I am web browsing and sometimes playing games.

What happens is that it randomly shows the loading cursor and suddenly I am not able to open, click on or control anything except actually moving the mouse on the screen. After about 10-30 seconds, the system comes back to normal and just resumes all activity.

I know this is my SSD because I have a previous Hitachi 1TB HDD inside my system with W7 64 on it and when booted off of, the whole system works flawlessly.

It started doing this hanging/freezing about 30 days into my 1ST install on the SSD and I am currently on my 3RD. My first was in IDE mode so I thought that was the problem. For my 2ND, I installed it in AHCI and it still continued. On my 3RD, I did not know whether it was the OS's fault or not, so I just installed on IDE again. It still does this.

I have updated the motherboard drivers to the fullest as I could.

-What can I do to stop this from recurring again?
-Do I need to update anything else?
-Anything else I could do?

Please help!
Thanks:D
2 answers Last reply
More about problem
  1. Try updating your motherboard's BIOS to the latest version.
    Also make sure your SSD is on its latest firmware version.
  2. Dereck47 said:
    Try updating your motherboard's BIOS to the latest version.
    Also make sure your SSD is on its latest firmware version.

    Actually, the time around that it started happening, I did update my bios to the latest version, so maybe that could be the culprit. Maybe it was a negative effect of the MOBO bios being newer and the SSD having older firmware. Thanks, I'll try it out.
Ask a new question

Read More

SSD Storage