Sign in with
Sign up | Sign in
Your question
Closed

Problems with mobility radeon

Last response: in Graphics & Displays
Share
August 25, 2010 9:44:41 PM

Hi, so specs first:
MSI GX 623// Intel Dual core P7350 2.0 GHz (Oc possible to 2.4)//4 gb ram DDR2 (3072 mb working, 32 bit system)// Ati Mobility Radeon 4670 512 MB ram GDDR 3// 500 GB 5400 HDD// Win7 Home Premium 32 bit.
Catalyst version: 10.7
Driver Version:D river Packaging Version 8.753-100706m-102501C-ATI


Now, my problem is White screen frezze with sound buzzing in all unreal engine based games.
All the tested games and confirmed same problem: GTA4,Gears of war,Singularity,Mass effect 1 (Mass effect 2 works just fine...),Unreal Tournament 3, Starcraft 2 (this alst one works well if all settings are set to minimum).

Now, some of those games crash into this white screen more often if they have high settings, others crash in specific places (mass effect) no matter the detail level, and some crash after a certain amout of time playing (UT3).

Anyone knows anything about this? I was trying to look for a possible answer, but since mobility arent oficially supported for games....
If i forgot to add any information, tell me.

P.S: i try to keep up to date most of my software, DitectX, drivers, etc.

Thank you for your help in advance!

More about : problems mobility radeon

August 26, 2010 3:31:12 AM

try use the older driver, like 10.3 or 10.4...
August 26, 2010 3:38:23 AM

What OS do you have? Make sure you have all the updates, the games' updates, try reinstalling Catalyst.
Related resources
August 26, 2010 8:50:49 AM

tried older catalyst, same effect, have all game updates, no effect. 8(
August 26, 2010 9:58:07 AM

Try doing a clean install of an older driver(like 10.5),because sometimes if you don't do a clean install,you may see some artifacts in games,here is how
1_Download and install "Driver sweeper" from Guru3d.com and install
2_Go to add/remove programs and uninstall the driver and reboot
3_Boot to safe mode and open driver sweeper,then click on Nvidia and then click on clean
4_Reboot and boot normally to windows and install the new drivers after that you need to restart,and its done
August 27, 2010 8:56:46 AM

I had those problems since the first drivers that came along with the laptop, thats the only reason i started updating the drivers for the ati...
I cant be sure but it looks like its some engine part that normal ATIs have, and mobility versions Lack. I dont have any problems with any other games apart from the unreal engine ones, no matter the detail level, they have no artifacts or anything else.
I wanted to find out if it was a overheating issue (i would replace thermal paste at least), but unfortunatelly when the white screen shows up, all com frezzes, so i cant alt tab, or CTRL+ALT+SUPR.
Who knows, it might be an issue with sound in unreal engine games...
August 29, 2010 11:52:00 AM

Update: Now Stalker call of prypiat gives me this bug also.
Any ideas?
September 2, 2010 12:01:46 PM

Bump, in amd forum no answer at all... plz help 8(.
September 2, 2010 2:01:18 PM

Your card maybe defective then, download and run 3Dmark vantage and check if it passes without any errors or not
September 3, 2010 9:27:18 AM

I uninstalled Nvidia physx and stalker running now 4 hours no crash...
Mayb its the Nvidia claim that they wont allow physx in use with ATI graphics cards?
September 3, 2010 9:58:33 AM

Update: Now it crashed, and suddpenly every game is asking me to install physx... is that normal?
September 3, 2010 6:15:53 PM

Every game ? or just the games that require PhysX ?
September 9, 2010 10:36:00 AM

Im not sure, but as far as i can remmber, any DX10 game crashed like that at least once, only game that stays working is mass effect 2, and now i got last drivers for both GPU and physx. I know its odd, i thought it could be an overheating problem, but then mass effect 2 should do same thing....
September 9, 2010 4:48:29 PM

Also Stalker call of prypiat now wont turn on (says my graphics card dosent meet the minimum requirements), thou stalker clear sky works quite well...

Im trying to figure this out but im starting to get depressed at it 8(.
September 9, 2010 4:50:29 PM

Why would you have PhysX installed in the first place?
Use driver sweeper to wipe out every single driver from ATI/Nvidia in safe mode and do a fresh install of ccc. Then monitor temps.
September 10, 2010 3:03:48 AM

What's your temps?
November 8, 2010 2:22:58 PM

Now it's getting really interesting the info stops.

I have simullar probs and m y temps reach over 90 degrees Celcius. Both CPU end GPU en crashes with a black screen, sound on (looing).
November 8, 2010 2:35:02 PM

jadebo said:
Now it's getting really interesting the info stops.

I have simullar probs and m y temps reach over 90 degrees Celcius. Both CPU end GPU en crashes with a black screen, sound on (looing).

Start a new thread then because this one has been dead for nearly two months.
!