Sign in with
Sign up | Sign in
Your question

Network printer doesn't show

Last response: in Networking
Share
May 4, 2010 1:20:20 PM

I have this really frustrating problem of a printer/copier connect via ethernet cable to the network not being discoverable.
It's a very simple set up with the printer going directly into a modem/router, and my computer going directly into it as well.
As it happens, my old router (it had to go because internet was unreliable) had no problems:
When I clicked on "Search for new printer" (under Windows 7), the printer would come up immediately, working without problems. But now with the new router, it simply wouldn't show up. I also tried to add it by entering the IP address manually, but it comes up with a message saying that the printer cannot be found.
With my old router I never had to set up anything further, it would work just straight out of the box, and I can't see anything in the setup of the new router that I should change, but perhaps there is?
Contacted manufacturers, they said they can't comment on 3rd party equipment (presumably blaming the router).

Have I overlooked something?

More about : network printer show

May 4, 2010 3:52:30 PM

Can you print a config page from the printer? Make sure it has the correct IP information. Then make sure you can ping the address.
May 4, 2010 6:26:14 PM

I tried to ping it, but it doesn't go through.
I also plugged the printer into an ethernet switch box to see if that would make a difference, but it's still not visible...
Related resources
May 4, 2010 11:17:27 PM

Make sure that the IP is in the same range as the new equipment, especially if it was msnually assigned. It couuld be the printer is still at 192.168.1.2 while with the new router all equipment is 192.168.0.3 ir whatever.
May 5, 2010 2:17:30 PM

The printer is on 192.168.1.99
The router's address is 192.168.2.1.
Sorry, I'm not very knowledgeable with IP addresses and stuff. Does that give any kind of information?
May 5, 2010 6:40:24 PM

could be an issue depending on your network mask. You can either make sure the mask is 255.255.0.0 or put them all in the 192.168.1.x range
May 5, 2010 6:51:25 PM

Naujoks said:
The printer is on 192.168.1.99
The router's address is 192.168.2.1.
Sorry, I'm not very knowledgeable with IP addresses and stuff. Does that give any kind of information?


That is your problem right there, your printer should be at 192.168.1.2.99, not at 192.168.1.99. The first three sets of numbers on a IP have to be the same for the devices to communicate without an enterprise level piece of equipment.
May 5, 2010 8:52:26 PM

I changed the IP on the printer, and it works now!
Thanks a lot!
May 6, 2010 11:58:34 AM

sk1939 said:
That is your problem right there, your printer should be at 192.168.1.2.99, not at 192.168.1.99. The first three sets of numbers on a IP have to be the same for the devices to communicate without an enterprise level piece of equipment.


well, your first IP there has a few too many numbers. Typo?

Also your 2nd statement is wrong. Just plain wrong. The "level of equipment" has nothing to do with it - it's about the IP mask.
May 6, 2010 12:58:44 PM

gtvr said:
well, your first IP there has a few too many numbers. Typo?

Also your 2nd statement is wrong. Just plain wrong. The "level of equipment" has nothing to do with it - it's about the IP mask.


It is a typo and how so? If you know of any other way to get a computer with an address of 192.168.2.2 and one of 192.168.1.1 using a SOHO router, please let me know. I certainly can't think of a way to get it to work cost effectively.
May 6, 2010 2:54:16 PM

You said IP address of "192.168.1.2.99" - that's 5 octets. You probably meant 192.168.2.99.

I picked a random linksys router, the WRT54GH from their web site - only allows 253 addresses in the .1.x subnet. So I picked another - the WRT160N does the same thing. OK, so current linksys routers don't allow you to assign a subnet mask. That means they suck.

Trying netgear: WGR614v9. Victory! This allows setting the subnet mask. I'm going to guess that other netgear routers do the same. So that would allow a 192.168.1.x device to talk to a 192.168.2.x device, by using a subnet mask of 255.255.0.0.
May 7, 2010 4:14:51 AM

gtvr said:
You said IP address of "192.168.1.2.99" - that's 5 octets. You probably meant 192.168.2.99.

I picked a random linksys router, the WRT54GH from their web site - only allows 253 addresses in the .1.x subnet. So I picked another - the WRT160N does the same thing. OK, so current linksys routers don't allow you to assign a subnet mask. That means they suck.

Trying netgear: WGR614v9. Victory! This allows setting the subnet mask. I'm going to guess that other netgear routers do the same. So that would allow a 192.168.1.x device to talk to a 192.168.2.x device, by using a subnet mask of 255.255.0.0.


That works in logic, but you'd still have to disable the built in firewall as well. Ok, granted you could do it, but I don't understand the reason a normal home user would need for such a thing.
May 7, 2010 5:22:46 AM

I think gtvr just meant expanding the subnet behind the router / firewall to include the printer's IP... however that would involve changing the mask in dhcp, any manually configured IP's, and the printer.... and if you want to do it "right" on the router / firewall's internal interface. Either way though I think it makes a lot more sense just to fix a single IP than to change the mask on everything on the network...
May 7, 2010 5:41:16 AM

I also plugged the printer into an ethernet switch box to see if that would make a difference, but it's still not visible...

Get Awesome Massage
May 7, 2010 11:32:56 AM

Brian_tii said:
I think gtvr just meant expanding the subnet behind the router / firewall to include the printer's IP... however that would involve changing the mask in dhcp, any manually configured IP's, and the printer.... and if you want to do it "right" on the router / firewall's internal interface. Either way though I think it makes a lot more sense just to fix a single IP than to change the mask on everything on the network...


My original statement was "You can either make sure the mask is 255.255.0.0 or put them all in the 192.168.1.x range" - I agree that it's easier to change 1 setting than multiple settings (usually). My discussion was mostly about the statement that you need enterprise level equipment to change a subnet mask, which is false.
!