Sign in with
Sign up | Sign in
Your question

External drive-USB 3.0 WD SATA does not connect

Last response: in Storage
Share
January 20, 2013 4:37:12 AM

Hi guys
Kind of dont know what to do more so I will appreciate any help.
I ve got my WD 640GB SATA drive in an USB 3.0 external box on my ASUS N76 Laptop with WIN7HP. It worked just fine. Then after few months I tried to connect it to the laptop but it wasnt visible in the Explorer. It was visible in the device manager with its correct name, but not visible in DIsk managment. After restart with the external drive connected WIN would not start no way after 30 minutes. Indeed it did after unplugging the cable of the box. I tried to plug it in a normal desktop PC with WIN7 and it worked just fine.I tried to format it, I had no important data there. It also connected to a Synology NAS very well.
So I decided to reinstal WIN on my Laptop hoping that everything would be fine after that. I backuped my data from the laptop through live distro where the drive was seen right away after plugging. Now I have my WIN reinstalled and after I plug it in the laptop, IT IS THE SAME OVER AGAIN. I cannot see it in the explorer. What is this? It seems impossible. DOes it have bad drivers? But how, when it worked before? THe drive is OK, it worked on two different machines. It workes on the same laptop under Linux running....I am really out of any idea. PLease help.
a b D Laptop
a c 79 G Storage
January 20, 2013 2:44:03 PM

Check very carefully in Disk Management again.

In the bottom-right panel, do you see a ribbon which has no drive name or letter, and it usually says "Raw"?
If yes, that's probably why you missed it the first time. You were probably looking for the drive's name which wasn't there.

Right-click that ribbon and choose "Change Drive Letter and Paths".
Click "Add" (or it may say "New").
Choose a letter from the drop-down box.
Click "Okay"

Wait a few seconds and the ribbon should show the drive's name together with a drive letter.

Windows often fails to assign a drive letter on some computers when you plug-in an external drive.
The problem doesn't always occur, and doesn't occur on all computers, which is why the drive worked fine on a different PC.

Finally, it is not unusual for a PC to refuse to "POST" while an external hard drive is plugged in to it.
It happens on mine too. It doesn't mean there's something wrong with the drive or your PC.
Just ensure the drive is unplugged from the PC before you turn the PC on.
January 20, 2013 3:18:26 PM

I checked but I see nothing like that in the Disk managment. And I have news. When I keep the disk connected a long time, like an hour, it shows up in the Computer, like a "DISK H:", and later the popup says I have to format it before using. I almost pressed enter by mistake and formatted my backuped data!!
Anyway, I ve copied the backed up data to my HDD on the LAPTOP using Mint distro, where the disk works perfectly. Now I will connect it to Synology and us it as another storage.
It s quite weird but I am happy I didnt lose my data. :bounce: 
Related resources
!