Force 3 240GB disconnect/disapears

Hi guys,

I hope some of you can help me.

I run a Force 3 240GB SSD as a secondary drive. It has been working fine for the last 3-4 months. I started having issues with it last week.

This is what happens: The drive is working correctly, when all of a sudden my system start freezing for about 30 seconds, then the drive disappears and my computer works just fine, but I can't access the drive anymore(it isn't in the Computer Drives screen).
When I restart my computer, the drives reappears and works well for some time til my system start freezing again.

It seems like if I do file transfer with it, it does crash after like 10 minutes or so. If I don't do anything with it there wont be any trouble(I did let my computer open all night and the drive was still working on the morning).

I did Update my Bios. The drive is running under firmware 5.02 since I bought it.
I also changed the Sata cable and Sata port.

In Windows Event Viewer, at the time the drive crash, there is a bunch of
-Application popup: Windows - Delayed Write Failed (Application Popop, Event ID 26)
-The device, \Device\Harddisk1\DR1, is not ready for access yet (Disk, Event ID 15)
-The system failed to flush data to the transaction log. Corruption may occur. (Ntfs, Event ID 57)


I don't want to RMA yet cause I feel the drive is still working fine. It might be something else that cause the problem.
3 answers Last reply
More about force 240gb disconnect disapears
  1. Can you try another SATA Port?
    Did you backup important files from the drive?
    You can try to check SMART values with CrystalDiskInfo.
  2. I did tried with another sata cable and sata port but the same thing happens.

    There isn't really important data on this file. Mostly softwares and games. I did backup what I needed to keep.

    I'll check with CrystalDiskInfo tonight.
  3. Have you applied the firmware updates for your drive?

    http://forum.corsair.com/v3/showthread.php?t=110257
Ask a new question

Read More

SSD Connection Computer Storage