My saphire 5770 running WoW choppy why?

system specs:

BIOSTAR TA785G3 HD

AMD am3 athlon quad core 2.8 GHz temps- 27c-38c

SAPHIRE 5770 10.8 drivers Temps-38c-57c

I-INC 19in screen resolution 1366 x 768 (wide)

4 gb's of DDR3 RAM 1333MHz

186 HDD

Win 7 64 bit



Well basically when i play World of Warcraft it doesn't run the game smoothly. For example if i were to make a 360 degrees turn it would look very choppy but i would still have 60 FPS regardless with V sync on. I tested the card on Battlefield bad company 2 and i get 40-60 fps and Bioshock i get constant 60 fps and runs smoothly unlike WoW it gets so choppy i don't even wanna play the game at times. I've tryed reinstalling the drivers like 3 times and cleaning registry but nothing, i even tried reinstalling the game and the same thing happens. Alright so just now i changed the WoW to run in window mode and it got rid of the choppyness when i did the 360 turn but when i went into a 25 man raid the background choppyness continued.



My MS in game never goes above 200 by the way.
9 answers Last reply
More about saphire 5770 running choppy
  1. The others games are good, this is mean that the problem is WoW itself...
  2. Have you tried running it with V-sync disabled ? also try lowering AA/AF if you have used them
  3. Yeah i have but i get terrible screen tearing and yes i did lower AA in game to 1. As for AF i'll try it out.
  4. WoW is a strange game when it comes to performance. I can say this since I am a player. Got 6 accounts on one server and a 7th on molten. Wow doesn't scale very well at all in multy gpu setups. cpu wise its a pain and doesn't like low clocks unless it is at low to med settings. Drivers make odd fps with this game. So wipe the drivers (not the chipset drivers now) and try again. You can also delete the cache folder in wow or repatch then see if things improve. 700hours game play on main char.
  5. maybe its actually a broadband issue..
    try using another game in multiplayer...
    otherwise, i have ano clue...
    I wish you luck!!!
  6. OP,

    I run WoW from time to time and I've notice that with multi-monitor setups in windowed mode it can be a little touchy. I tend to clip out at 50-60 FPS regardless of V-sync or not. Turn off V-Sync and try this for me.

    Run the game in windowed mode on the monitor which you have selected as "Primary" on windows. The one with the start menu. See if that helps, because it did for me. For some reason WoW likes to be run on the primary monitor.
  7. I'll try that dual monitor out i guess but first im going to borrow my aunt's 23 inch with much bigger resolution and color to see if that will fix it.
  8. i know whats that about cuz i got same gpu same game

    its becuz of draw distance put the setting in the middle and the shadows the same

    and u should get a 60 fps in every were expect dalaran
  9. i found the only solution to your problem, since just now i have fixed it. You must have WoW installed in your Windows 7 drive under Program Files. WoW cannot be on a separate HD or Partition. It must be in Windows 7 Drive so Windows 7 can see it as a Windows 7 Program. Also right click on Wow launcher or shortcut and go to properties: select Windows XP SP3 or Windows Vista Compatibility, and also select Run as Administrator.

    but for other games that use GPU mostly such as MW2, black ops it doesnt matter if its on other HD. BUT WoW must Me in Windows 7 program files directory, since WoW uses CPU more.

    WiNDOWS 7 loads its folders and uses its default amount of CPU (therefore WoW in same Drive) keeps CPU working at Normal loads without having to read other drives simoutaneously.

    I am in no way an expert, but I have solved the problem doing this. Try it out. Make sure you have enough room in your default Win 7 drive to install WoW. I had to reformat my HD to make more room just so wow can fit on my Win 7 C drive, while my other games are on different HD.
Ask a new question

Read More

Radeon World Of Warcraft Graphics