Sign in with
Sign up | Sign in
Your question

Stuttering HD Playback on Gigabit Network

Last response: in Components
Share
January 8, 2011 4:48:04 AM

Let me start with my setup:

Network:
Belkin G Wireless Router
Netgear Unmanaged Gigabit Switch

HTPC:
AMD Phenom II 955
4GB DDR3
160 SATA HD
ATI Radeon HD 4200 (OC'd to 680MHz with 1GB Memory)
Gigabit NIC
Windows Media Center
Shark007 Win7 Codec 32/64-bit with Shark007 suggested settings
Connected to Netgear switch

Media-Server:
AMD Phenom X3 8450
8GB DDR2
Severa HDs housing media files (HD, SD, TV Videos, etc.)
Gigabit NIC
Connected to Netgear switch

Video:
1080p, DTS, MKV

Okay. When I playback high definition movies on the HTPC (streaming from the Media-Server) I get stuttering. I have attempted to troubleshoot this and I've narrowed it down my network configuration. However, I'm stuck.

If I change the network settings (Speed & Duplex) on both PCs to 1Gigabit Full, it works for a day, maybe two. Then I have to change it back to Auto Negotiate to make it work again.

Copying files from one PC to the other does not have any issues. It's only when I playback movies. I have tried VLC, Total Media Theatre, Windows Media Center, Media Player, and Media Player Classic. They all have the same issue.

If I copy the video file to HTPC hard drive, it plays like a dream.

I cannot figure this out. Any help would be greatly appreciated.
January 8, 2011 4:49:12 AM

doublej0 said:
Let me start with my setup:

Network:
Belkin G Wireless Router
Netgear Unmanaged Gigabit Switch

HTPC:
AMD Phenom II 955
4GB DDR3
160 SATA HD
ATI Radeon HD 4200 (OC'd to 680MHz with 1GB Memory)
Gigabit NIC
Windows Media Center
Shark007 Win7 Codec 32/64-bit with Shark007 suggested settings
Connected to Netgear switch

Media-Server:
AMD Phenom X3 8450
8GB DDR2
Severa HDs housing media files (HD, SD, TV Videos, etc.)
Gigabit NIC
Connected to Netgear switch

Video:
1080p, DTS, MKV

Okay. When I playback high definition movies on the HTPC (streaming from the Media-Server) I get stuttering. I have attempted to troubleshoot this and I've narrowed it down my network configuration. However, I'm stuck.

If I change the network settings (Speed & Duplex) on both PCs to 1Gigabit Full, it works for a day, maybe two. Then I have to change it back to Auto Negotiate to make it work again.

Copying files from one PC to the other does not have any issues. It's only when I playback movies. I have tried VLC, Total Media Theatre, Windows Media Center, Media Player, and Media Player Classic. They all have the same issue.

If I copy the video file to HTPC hard drive, it plays like a dream.

I cannot figure this out. Any help would be greatly appreciated.

Oh... also... all drivers are up to date.
January 8, 2011 4:32:01 PM

Download and install VLC and see if it performs any better. Just a thought.

Your network config looks ok How fast are the HDDs on the media server?
Related resources
January 11, 2011 12:26:08 PM

So I posted this on AVS Forum also and the suggestion and solution was to back off the Network Throttling from 10 to 50. After the change, I have not had any stuttering 3 days straight. Another suggestion, which I don't have the funds for yet, is to purchase a managed switch and also change the NIC drivers from realtek drivers to M$ drivers. I'll examine with that another time.
January 11, 2011 12:31:01 PM

A managed switch will be an expensive overkill and unless you are familiar with SNMP and how to manage the switch a waste of time and money. You should be fine with the switch you have now.

Regarding the drivers, use the most recent/current version from the network adapter chipset vendor.

Did you try VLC, BTW?
April 29, 2011 3:05:53 PM

I had the same problem, thought it was network related, it wasn't. Use VLC's latest, 1.1.9 and go to "tools" then "preferences", then "inputs and codecs" and click the box "Use GPU Acceleration (experimental)" This cleared my stuttering up instantly, I mostly watch 1080p MKV movies with surround sound, no problems. You can also try using the system codecs as well instead of vlc, which is just below the gpu acceleration box.
!