Sign-in / Sign-up
Your question

Disabling eject options?

Tags:
  • SSD
  • Flash Drive
  • Storage
Last response: in Storage
January 21, 2013 4:29:51 PM

I recently built my new pc and I just noticed the other day when I was transferring files to my flash drive that Windows is giving me the option to eject my boot SSD and my data HDD. Granted I am not dumb enough to do this but I don't feel comfortable having those options available. Does anyone know how to disable those options? Thanks.

More about : disabling eject options

a b G Storage
January 21, 2013 4:46:58 PM

Hello... go to properties for each drive in question... and look at the policies enabled... write caching enabled on some type of drives will do this.
m
0
l
a c 590 G Storage
January 21, 2013 4:51:50 PM

Check your BIOS settings. Seems like the port your SSD is connected to has Hot Swapping or Hot Plugging enabled.

Disable the setting and your O/S should no longer give you an option to eject the drive.
m
0
l
November 24, 2014 11:39:16 AM

I just finished a new build,windows 7, z97 extreme4 with Samsung 850 ssd, i5 processor, kept getting the safely remove icon for the ssd drive. After a lot of experimenting I found I had the sata cable for the ssd in the wrong slot, should go in the SATA3_0 and not in SATA3_A0. I have used this forum for help for a while so I thought I'd give some back. ; ) happy building!
m
0
l