Sign in with
Sign up | Sign in
Your question

Some flickering on my screen

Last response: in Graphics & Displays
Share
August 27, 2010 10:58:39 PM

Hey, it's a simple question, but here it goes. When I play crysis with most settings on very high I get some flickering on my screen. It looks like a horizontal "line" on my screen, and it is seems to be caused by a picture that is overlapping the previous one. My fps seems OK, and this is not the way of lag I am used to. So what is this, and can I fix it?

Thanks.


System:

My graphics card: XFX radeon 5870.
processor: Phenom II x4 965 quad
ram: 4gb ddr3 cl7 1333 mhz(I'm not sure if it was called Mhz, but bear with me)
monitor: Samsung syncmaster p2370. I am using the DVI cable that is following with it.

More about : flickering screen

a c 153 U Graphics card
August 27, 2010 11:49:11 PM

Turn on vertical sync. =]

The "tearing" is caused by the frame rates being higher then the screen refresh rate. Vsync will locks these at the same rates.

Quote:
Tearing

It is an unfortunate fact that if you disable VSync, your graphics card and monitor will inevitably go out of synch. Whenever your FPS exceeds the refresh rate (e.g. 120 FPS on a 60Hz screen), or in general at any point during which your graphics card is working faster than your monitor, the graphics card produces more frames in the frame buffer than the monitor can actually display at any one time. The end result is that when the monitor goes to get a new frame from the primary buffer of the graphics card during VBI, the frame may be made up of two or more different frames overlapping each other. This results in the onscreen image appearing to be slightly out of alignment or 'torn' in parts whenever there is any movement - and thus it is referred to as Tearing.
August 28, 2010 12:40:37 AM

I'll take a look at it, but it seems strange, because it is perfect when I am running at lower settings. It is just getting that tearing when I am adjusting the settings higher.
However, thanks alot :) 
a c 153 U Graphics card
August 28, 2010 12:54:46 AM

Just enable vsync it should solve your problem.
!