Sign in with
Sign up | Sign in
Your question
Closed

How to remove write protection from micro sd card

Last response: in Storage
Share
January 23, 2013 3:53:44 AM

Here are detailed steps for you:
1. Plunge this drive or memory card to a computer. (Of course, you should use a card Reader to connect your memory card.)
2. Click “Start” on the taskbar to open “Run” and type in “regedit”.
3. Hit “HKEY_LOCAL_MACHINE” to expand “System”.
4. Find “Current Control Set” in “System” list to click “Control”.
5. Check whether there is a key named “Storage Device Policies” to change the digit in the “DWORD value” box into "0" and press “OK”.
But, if you cannot find the key named “Storage Device Policies”, you are supposed to create a one: right click “Control” to create a new key and name it as “Storage Device Policies”=> right click this new key to open “DWORD Value” and name it as “write protect”=> Double click it to change number.
Score
0
February 20, 2013 1:28:56 PM

QuEEni3eKimi said:
Here are detailed steps for you:
1. Plunge this drive or memory card to a computer. (Of course, you should use a card Reader to connect your memory card.)
2. Click “Start” on the taskbar to open “Run” and type in “regedit”.
3. Hit “HKEY_LOCAL_MACHINE” to expand “System”.
4. Find “Current Control Set” in “System” list to click “Control”.
5. Check whether there is a key named “Storage Device Policies” to change the digit in the “DWORD value” box into "0" and press “OK”.
But, if you cannot find the key named “Storage Device Policies”, you are supposed to create a one: right click “Control” to create a new key and name it as “Storage Device Policies”=> right click this new key to open “DWORD Value” and name it as “write protect”=> Double click it to change number.



DID NOT WORK??
Score
0
Related resources
February 20, 2013 1:39:43 PM

1. Plunge this drive or memory card to a computer. (Of course, you should use a card Reader to connect your memory card.)
2. Click “Start” on the taskbar to open “Run” and type in “regedit”.
3. Hit “HKEY_LOCAL_MACHINE” to expand “System”.
4. Find “Current Control Set” in “System” list to click “Control”.
5. Check whether there is a key named “Storage Device Policies” to change the digit in the “DWORD value” box into "0" and press “OK”.
But, if you cannot find the key named “Storage Device Policies”, you are supposed to create a one: right click “Control” to create a new key and name it as “Storage Device Policies”=> right click this new key to open “DWORD Value” and name it as “write protect”=> Double click it to change number



DID THIS - WHAT NUMBER SHOULD I ENTER FOR DWORD VALUE? ITS ALREADY ON 0
Score
0
May 8, 2013 3:22:26 PM

johnnyg3000 said:
1. Plunge this drive or memory card to a computer. (Of course, you should use a card Reader to connect your memory card.)
2. Click “Start” on the taskbar to open “Run” and type in “regedit”.
3. Hit “HKEY_LOCAL_MACHINE” to expand “System”.
4. Find “Current Control Set” in “System” list to click “Control”.
5. Check whether there is a key named “Storage Device Policies” to change the digit in the “DWORD value” box into "0" and press “OK”.
But, if you cannot find the key named “Storage Device Policies”, you are supposed to create a one: right click “Control” to create a new key and name it as “Storage Device Policies”=> right click this new key to open “DWORD Value” and name it as “write protect”=> Double click it to change number



DID THIS - WHAT NUMBER SHOULD I ENTER FOR DWORD VALUE? ITS ALREADY ON 0


After doing this, get yourself a different USB adapter/card reader. Put the micro sd into it. Reinsert into your PC. Open Start > Computer. Right click on your device. Click "Format" and hey presto! I hope this works. it did for me.
Score
0
June 4, 2013 5:27:19 AM

PAULMC73 said:
johnnyg3000 said:
1. Plunge this drive or memory card to a computer. (Of course, you should use a card Reader to connect your memory card.)
2. Click “Start” on the taskbar to open “Run” and type in “regedit”.
3. Hit “HKEY_LOCAL_MACHINE” to expand “System”.
4. Find “Current Control Set” in “System” list to click “Control”.
5. Check whether there is a key named “Storage Device Policies” to change the digit in the “DWORD value” box into "0" and press “OK”.
But, if you cannot find the key named “Storage Device Policies”, you are supposed to create a one: right click “Control” to create a new key and name it as “Storage Device Policies”=> right click this new key to open “DWORD Value” and name it as “write protect”=> Double click it to change number



DID THIS - WHAT NUMBER SHOULD I ENTER FOR DWORD VALUE? ITS ALREADY ON 0


After doing this, get yourself a different USB adapter/card reader. Put the micro sd into it. Reinsert into your PC. Open Start > Computer. Right click on your device. Click "Format" and hey presto! I hope this works. it did for me.



Hi Roxysaures101!

I tried the above.. and its still not working :(  can you please suggest anything else?
Score
0
June 15, 2013 1:00:51 AM

Hi,

It works for me. Mine is Kingston 32GB.

I have done it step by step according to the guide.

I also did check disk on my micro sd card and the system detected some errors and fixed it.

Finally, my micro sd card back to its normal function again :) 
Hopefully it helps.
Score
0
July 24, 2013 2:36:48 PM

Nandan Raghothama said:
PAULMC73 said:
johnnyg3000 said:
1. Plunge this drive or memory card to a computer. (Of course, you should use a card Reader to connect your memory card.)
2. Click “Start” on the taskbar to open “Run” and type in “regedit”.
3. Hit “HKEY_LOCAL_MACHINE” to expand “System”.
4. Find “Current Control Set” in “System” list to click “Control”.
5. Check whether there is a key named “Storage Device Policies” to change the digit in the “DWORD value” box into "0" and press “OK”.
But, if you cannot find the key named “Storage Device Policies”, you are supposed to create a one: right click “Control” to create a new key and name it as “Storage Device Policies”=> right click this new key to open “DWORD Value” and name it as “write protect”=> Double click it to change number



DID THIS - WHAT NUMBER SHOULD I ENTER FOR DWORD VALUE? ITS ALREADY ON 0


After doing this, get yourself a different USB adapter/card reader. Put the micro sd into it. Reinsert into your PC. Open Start > Computer. Right click on your device. Click "Format" and hey presto! I hope this works. it did for me.



Hi Roxysaures101!

I tried the above.. and its still not working :(  can you please suggest anything else?


i had the same problem so i tried this and it didnt work but then i realised my microSD adapter had a little switch on it that locks it, i just flicked the witch to unlock it and it worked fine
Score
0
July 25, 2013 5:30:21 AM

ohfekjr said:
Nandan Raghothama said:
PAULMC73 said:
johnnyg3000 said:
1. Plunge this drive or memory card to a computer. (Of course, you should use a card Reader to connect your memory card.)
2. Click “Start” on the taskbar to open “Run” and type in “regedit”.
3. Hit “HKEY_LOCAL_MACHINE” to expand “System”.
4. Find “Current Control Set” in “System” list to click “Control”.
5. Check whether there is a key named “Storage Device Policies” to change the digit in the “DWORD value” box into "0" and press “OK”.
But, if you cannot find the key named “Storage Device Policies”, you are supposed to create a one: right click “Control” to create a new key and name it as “Storage Device Policies”=> right click this new key to open “DWORD Value” and name it as “write protect”=> Double click it to change number



DID THIS - WHAT NUMBER SHOULD I ENTER FOR DWORD VALUE? ITS ALREADY ON 0


After doing this, get yourself a different USB adapter/card reader. Put the micro sd into it. Reinsert into your PC. Open Start > Computer. Right click on your device. Click "Format" and hey presto! I hope this works. it did for me.



Hi Roxysaures101!

I tried the above.. and its still not working :(  can you please suggest anything else?


i had the same problem so i tried this and it didnt work but then i realised my microSD adapter had a little switch on it that locks it, i just flicked the witch to unlock it and it worked fine



Score
0
July 29, 2013 8:13:41 AM

I found much quicker and better solution which worked on How to Remove write-protection:

1. Start > Run > cmd
2. type "diskpart" -> runs diskpart.exe from system folder
3. type "list volume" -> now you see all your connected drives, see which one is the drive
4. type "select volume #" -> # being the letter of your drive
5. type "attributes disk clear readonly" -> removing the protection
6. Then open your SD, you can now edit, delete, move files.
Score
0
August 9, 2013 5:34:26 AM

Roxysaures101 said:
how do i remove the write protection from my micro sd to put music / vids / pics ??????
Help Plz :non:  :hello: 


Score
0
August 11, 2013 2:15:03 PM

majesca said:
I found much quicker and better solution which worked on How to Remove write-protection:

1. Start > Run > cmd
2. type "diskpart" -> runs diskpart.exe from system folder
3. type "list volume" -> now you see all your connected drives, see which one is the drive
4. type "select volume #" -> # being the letter of your drive
5. type "attributes disk clear readonly" -> removing the protection
6. Then open your SD, you can now edit, delete, move files.


Score
0
August 11, 2013 2:15:27 PM

Love you boy :* :D 
Score
0
September 21, 2013 7:52:59 PM

QuEEni3eKimi said:
Here are detailed steps for you:
1. Plunge this drive or memory card to a computer. (Of course, you should use a card Reader to connect your memory card.)
2. Click “Start” on the taskbar to open “Run” and type in “regedit”.
3. Hit “HKEY_LOCAL_MACHINE” to expand “System”.
4. Find “Current Control Set” in “System” list to click “Control”.
5. Check whether there is a key named “Storage Device Policies” to change the digit in the “DWORD value” box into "0" and press “OK”.
But, if you cannot find the key named “Storage Device Policies”, you are supposed to create a one: right click “Control” to create a new key and name it as “Storage Device Policies”=> right click this new key to open “DWORD Value” and name it as “write protect”=> Double click it to change number.


it really works thanks a lot....
Score
0
September 24, 2013 8:47:41 AM

versalomy6 said:
Besides the registry key, sometime the sd card has a lock button at the side of the card,check it out.


Mine is a micro sd and it does not have a lock botton beside it, i've tried so many ways to format it and its not working, I also downloaded a sd card formatter and when i try to format, it keeps saying "write protector on"

I went further to try using command prompt but it stood still at 0percent for several hours and its getting really frustrating.

I've been able to backup all d files in it, all i need now is to turn off the write protect and format.

I need help. Anyone?

Score
0
October 8, 2013 1:40:52 PM

majesca said:
I found much quicker and better solution which worked on How to Remove write-protection:

1. Start > Run > cmd
2. type "diskpart" -> runs diskpart.exe from system folder
3. type "list volume" -> now you see all your connected drives, see which one is the drive
4. type "select volume #" -> # being the letter of your drive
5. type "attributes disk clear readonly" -> removing the protection
6. Then open your SD, you can now edit, delete, move files.


It hasnt worked for me... it said succesful, but I still cant delete the things on the sd card :??:  Help
Score
0
October 10, 2013 2:30:36 AM

versalomy6 said:
Besides the registry key, sometime the sd card has a lock button at the side of the card,check it out.


ohhh my man thanks a lot!! it actually worked!!! :D  its was bugging me for 4 months...thanks man
Score
0
October 26, 2013 11:40:17 PM

worked for meh :D 
Score
0
November 7, 2013 9:09:45 PM

ohfekjr said:
Nandan Raghothama said:
PAULMC73 said:
johnnyg3000 said:
1. Plunge this drive or memory card to a computer. (Of course, you should use a card Reader to connect your memory card.)
2. Click “Start” on the taskbar to open “Run” and type in “regedit”.
3. Hit “HKEY_LOCAL_MACHINE” to expand “System”.
4. Find “Current Control Set” in “System” list to click “Control”.
5. Check whether there is a key named “Storage Device Policies” to change the digit in the “DWORD value” box into "0" and press “OK”.
But, if you cannot find the key named “Storage Device Policies”, you are supposed to create a one: right click “Control” to create a new key and name it as “Storage Device Policies”=> right click this new key to open “DWORD Value” and name it as “write protect”=> Double click it to change number



DID THIS - WHAT NUMBER SHOULD I ENTER FOR DWORD VALUE? ITS ALREADY ON 0


After doing this, get yourself a different USB adapter/card reader. Put the micro sd into it. Reinsert into your PC. Open Start > Computer. Right click on your device. Click "Format" and hey presto! I hope this works. it did for me.



Hi Roxysaures101!

I tried the above.. and its still not working :(  can you please suggest anything else?


i had the same problem so i tried this and it didnt work but then i realised my microSD adapter had a little switch on it that locks it, i just flicked the witch to unlock it and it worked fine







it didnt work for meeeh
Score
0
November 7, 2013 9:15:54 PM

i have done everything but cant remove the write protection T_T
Score
0
November 14, 2013 12:05:51 AM

it worked for meeeee perfectly!!!!!!!!!!!! i think you guys should not leave spaces between each word and maintain the caps at the begining of each word.. something like this will help "StorageDevicePolicies" and "WriteProtect"........... you also have to restart your pc for it to take effect else you will beeeeeeeee an asssss!!!
Score
0
November 23, 2013 1:22:18 PM

QuEEni3eKimi said:
Here are detailed steps for you:
1. Plunge this drive or memory card to a computer. (Of course, you should use a card Reader to connect your memory card.)
2. Click “Start” on the taskbar to open “Run” and type in “regedit”.
3. Hit “HKEY_LOCAL_MACHINE” to expand “System”.
4. Find “Current Control Set” in “System” list to click “Control”.
5. Check whether there is a key named “Storage Device Policies” to change the digit in the “DWORD value” box into "0" and press “OK”.
But, if you cannot find the key named “Storage Device Policies”, you are supposed to create a one: right click “Control” to create a new key and name it as “Storage Device Policies”=> right click this new key to open “DWORD Value” and name it as “write protect”=> Double click it to change number.

what do i change the number to
Score
0
December 1, 2013 12:35:15 PM

100% work!
The solution that works for me perfectly is the one with regedit.
It is very important to add the missing key with no spaces between the words and every word start with capital letter:
StorageDevicePolicies ---> WriteProtect

There is no need to reboot your PC but recconect the card reader withthe micro SD needed.
Score
0
December 2, 2013 10:22:51 AM

it worked for me(the regedit),thanx a lot guys...
Score
0
!