Sign in with
Sign up | Sign in
Your question

Internal DVD writer acts now like a USB

Last response: in Storage
Share
January 23, 2013 3:19:56 PM

Hi. after a PC not booting i sent it for repair but when it was returned back, here is what I noticed.

The DVD writer is internal but it now shows in the system tray with the Safely remove hardware button and if I click on that then the drive is removed from My computer like a normal usb.

- is it ok to keep it as it is?
- is it possible that I put it back as it was before? I mean not via USB.

Thank you for all that can help.
a c 523 G Storage
January 23, 2013 4:03:34 PM

Check your BIOS settings. If your motherboard has Hot Swapping or Hot Plugging options then see if the port your DVD is connected to has that option enabled.

If so then disable it and the option to safely remove hardware should disappear.
m
0
l
January 23, 2013 4:45:13 PM

I checked the BIOS settings, but I see no hot swapping or hot plugging options in the BIOS. Do you know where that option may be? The nearest thing that I found in the BIOS is in the Configuration tab.

I will list level starting from top for the tab Configuration:
SATA Driver
Chipset SATA Mode: IDE, AHCI, RAID
S.M.A.R.T
SATA PORT 1: my dvd writer goes here

Second how can I see if the port my DVD is connected to has the Hot swapping or Hot plugging option? Do I open the case? What do I check for?

Thank you.
m
0
l
Related resources
a c 523 G Storage
January 23, 2013 8:30:37 PM

whiteant said:
I checked the BIOS settings, but I see no hot swapping or hot plugging options in the BIOS. Do you know where that option may be?


If you don't see those options then your motherboard doesn't support it, so there must be some other reason the DVD is showing up as a removable device.

What's the model of your motherboard?
m
0
l
January 24, 2013 11:58:11 AM



thank you but none of the solutions there wored, i tried all possible numbers for the Controller and for the Channel that was a hard 25 times of registry change and windows restart.

in Intel Rapid Storage Technology, i have a similar to what is in this image
http://imageshack.us/f/195/unlednj.png/
but instead of Internal ATAPI device i see External ATAPI device while my DVD writer is in reality Internal.

any more ideas please?
m
0
l
January 24, 2013 12:02:16 PM

Dereck47 said:
If you don't see those options then your motherboard doesn't support it, so there must be some other reason the DVD is showing up as a removable device.

What's the model of your motherboard?


my motherboard is the following:

http://www.intel.com/content/www/us/en/motherboards/des...

Perhaps it's something to do with how the DVD writer is connected to the motherboard?
tell me please if i should look inside the case and describe something in there.
m
0
l
a c 523 G Storage
January 24, 2013 12:44:44 PM

Change the SATA mode of the port the DVD is connected to to IDE and see if that helps.
m
0
l
January 24, 2013 5:59:53 PM

Thank you Dereck47 but I never did that before so i like to ask your help on how to do that.

do i open the tower to look inside and plug the DVD writer in some IDE connector?
is that what you mean?
m
0
l
a c 523 G Storage
January 24, 2013 7:05:52 PM

No, you don't need to open up anything. Reboot into your motherboard's BIOS and there should be SATA configuration settings in there where you can change SATA modes.
m
0
l
January 25, 2013 1:10:39 AM

I looked up the BIOS and here is what exists in the configuration tab from the top.

Sata Drives, then Chipset SATA Mode (IDE, AHCI, RAID), then S.M.A.R.T, then the list of the available SATA drives on ports from 0 to 5

i think that the option to change the DVD writer is in Chipset SATA Mode where i see:
- IDE
- AHCI. it is checked.
- RAID

but there is no possibility to change each port individually to IDE and if i change the Chipset SATA Mode from AHCI to IDE then not only the DVD writer will get changed to IDE but also all what is SATA like the Hard Drive.
m
0
l
a c 523 G Storage
January 25, 2013 1:25:08 AM

whiteant said:
but there is no possibility to change each port individually to IDE


That sucks. Sorry, don't know what else to suggest. Hopefully other members will be able to get your issue resolved.
m
0
l
February 3, 2013 2:16:23 PM

i hope the same, thank you anyway
m
0
l
!