Sign in with
Sign up | Sign in
Your question

ASRock P67 Extreme4 Problem

Last response: in Motherboards
Share
September 8, 2011 11:29:51 PM

Hello,

I've recently acquired computer parts to build a moderate gaming computer.

Parts are:
CPU: i5 2500k with Hyper212+
MOBO: ASRock p67 extreme4 B3
Ram: G.Skill ripjaws 8gb 1333
PSU: Silverstone Strider Plus 750 W
GFX: EVGA 560 ti sc
Case: CM Storm Scout

I assembled it a few times but it wouldn't boot due to small errors like forgetting the CPU power. My father then decided to help me but told me that the mobo was gone because he saw a spark. There is now a small burn between the Infrared Module Header and the Front Header. I decided to breadbox the mobo, cpu and one ram with the 560 ti and a signal was picked up by my monitor with the asrock logo which prompted me to move towards the final stage.

That was all good but I tried putting it back into my case which worked perfectly fine... and as I attached the molex power cables (for the case fans) to the psu several issues occured:

-the LEDS from the mobo stopped turning on
-No signal picked up by monitor
-Not able to turn off system with power switch or shorting pins. The only way is CMOS

I followed this guide with no sucess - http://www.tomshardware.com/forum/261145-31-perform-ste...

Any suggestions?

September 9, 2011 2:35:20 AM

Another note: When I connect everything again, the fans of the Ti card, case and cooler turn on but no display.
m
0
l
September 9, 2011 8:02:29 PM

I don't know if the warranty will work so I might get another ASRock unless there's something better than it for around $159 CAD?
m
0
l
!