Seagate GoFlex1TB HDD not assigned LETTER but shown on "safely remove"

Hi,

Seagate 1TB Goflex not detected, but shown in "Safely remove hardware" icon in system tray.
I have checked on DiskManagement and EaseUS and uploaded the screenshots as given below.
The HDD is working on my iMac.
I have changed my CDROM drive letter from M: to T: to accommodate any Letter assigning issue but it seems to be not working.

http://i50.tinypic.com/2jh0d1.jpg

http://i49.tinypic.com/i6z1og.jpg

http://i47.tinypic.com/34pyrex.jpg

Please let me know any solution.

Cheers
Hari
3 answers Last reply
More about seagate goflex1tb assigned letter shown safely remove
  1. Never mind the CD drive letter, have you tried assigning a letter to your GoFlex?
    Or "Initialize" it?
  2. Windows cannot natively mount a Mac file system. You need something like HFS Explorer (freeware) or MacDrive (commercial). HFS Explorer gives you read access only while MacDrive allows both read and write access.

    HFS Explorer :
    http://www.catacombae.org/hfsx.html

    MacDrive:
    http://www.mediafour.com/products/macdrive/standard/

    It won't help in your current situation, but just FYI Seagate provides a Paragon driver that enables a Mac to mount an NTFS file system:
    http://knowledge.seagate.com/articles/en_US/FAQ/216511en
  3. Thanks fzabkar.
    That worked like a charm.Yes, it was the issue with Mac file system.

    Hari
Ask a new question

Read More

Hard Drives Hardware Seagate Storage