Sign in with
Sign up | Sign in
Your question

The Windows Installer service terminated unexpectedly

Last response: in Windows XP
Share
Anonymous
September 9, 2005 6:20:59 PM

Archived from groups: microsoft.public.virtualpc,microsoft.public.windowsxp.configuration_manage,microsoft.public.windowsxp.general (More info?)

Windows XP Pro, SP2 running inside MS Virtual PC 2004. (Not that the latter
should make any difference - theoretically.)

I am no longer able to install MSI's on this box. The MSI will launch,
Preparing to Install... and then I receive the following dialog box:

The Windows Installer Service could not be accessed. This can occur if you
are running Windows in Safe mode, (I'm not) or if the Windows Installer is
not correctly installed (it should be - see below).

In the event log, I see three messages:

1. The Windows Installer service was successfully sent a start control.
2. The Windows Installer service entered the running state.
(so far, so good...)
3. The Windows Installer service terminated unexpectedly. It has done this n
time(s).
This is Event ID 7034 from Service Control Manager

I've upgraded the MSI subsystem to 3.1 using

http://www.microsoft.com/downloads/info.aspx?na=208&p=3...

But this didn't solve the problem. Looking at Add/Remove Programs from the
Control Panel, I can see that I've definitely installed a few MSI's in the
past. What could be wrong that an MSI subsystem upgrade wouldn't fix and how
can I fix this?

Thanks for your help!

- Joe Geretz -
September 9, 2005 11:36:28 PM

Archived from groups: microsoft.public.virtualpc,microsoft.public.windowsxp.configuration_manage,microsoft.public.windowsxp.general (More info?)

Try these links. I am having a similar problem with a WinXP Pro
Laptop. Double clicking on a MSI file starts the install, then
it just disappears. No error messages at all. The install never happens.
In Task Manager, there are 3 instances if msiexec.exe, one of which is
using 50+ % of CPU resources.

I tried the following links, but they didn't help - but they might fix your
problem. Not sure what to do with this laptop.

http://support.microsoft.com/default.aspx?scid=kb;en-us;886630

http://support.microsoft.com/default.aspx?scid=kb;en-us;555175




"Joseph Geretz" <jgeretz@nospam.com> wrote in message news:uZPsRtWtFHA.2064@TK2MSFTNGP09.phx.gbl...
> Windows XP Pro, SP2 running inside MS Virtual PC 2004. (Not that the latter should make any
> difference - theoretically.)
>
> I am no longer able to install MSI's on this box. The MSI will launch, Preparing to Install... and
> then I receive the following dialog box:
>
> The Windows Installer Service could not be accessed. This can occur if you are running Windows in
> Safe mode, (I'm not) or if the Windows Installer is not correctly installed (it should be - see
> below).
>
> In the event log, I see three messages:
>
> 1. The Windows Installer service was successfully sent a start control.
> 2. The Windows Installer service entered the running state.
> (so far, so good...)
> 3. The Windows Installer service terminated unexpectedly. It has done this n time(s).
> This is Event ID 7034 from Service Control Manager
>
> I've upgraded the MSI subsystem to 3.1 using
>
> http://www.microsoft.com/downloads/info.aspx?na=208&p=3...
>
> But this didn't solve the problem. Looking at Add/Remove Programs from the Control Panel, I can
> see that I've definitely installed a few MSI's in the past. What could be wrong that an MSI
> subsystem upgrade wouldn't fix and how can I fix this?
>
> Thanks for your help!
>
> - Joe Geretz -
>
!