Sign in with
Sign up | Sign in
Your question

Storage device not seen in My Computer but seen in Disk Management

Last response: in Storage
Share
January 24, 2013 10:16:10 AM

Hello guys,

I need help in trying to re access my WD external hard drive 500gb.
I've been using it for quite some time and it suddenly turned unreadable.
Whenever I plugged it to PCs, the usual beep is heard and the system has read it that there is a usb connected but the autorun for the device is not working anymore.

When I tried to view the storage in the Disk Management, it was there but UNALLOCATED.

I tried to initialize it like what I read in forums but the media is WRITE-PROTECTED as shown below.




I tried the storagepolicydevice thing in the regedit but I can't still be fixed.

Can anyone help me to access my files in the external HD??
I need it badly.
a c 82 G Storage
January 24, 2013 11:35:25 AM

Does the drive spin? You could remove it from the external enclosure and connect it directly to your system.

If you need your data badly, be very careful not to make the issue worse. Sending it to a recovery service may be your best option. Didn't you keep a copy of your data on your system as well as the external drive?
m
0
l
January 31, 2013 1:35:05 PM

It spins but stops.
I dont know how to remove it and put it directly into my system

I have copy of new files but the old files are there.
So I really need it.

Anything else we could?
m
0
l
Related resources
a c 82 G Storage
January 31, 2013 9:20:05 PM

Not much else by yourself. If you really need your data, then my original recommendation still is valid.
m
0
l
a c 311 G Storage
February 2, 2013 1:14:53 AM

@solegrin, your drive is reporting a bogus capacity of 2TiB (not 2TB). This is symptomatic of an internal physical fault with the drive itself.
m
0
l
!