Sign in with
Sign up | Sign in
Your question

2nd 4870 1gb will not link! help

Last response: in Graphics & Displays
Share
August 30, 2010 5:14:31 PM


Hi, i just recently bought a 2nd radeon 4870 hd 1gb diamond for crossfire. I installed the 2nd card and it says the first card is enabled but the 2nd says disabled adapter instead of linked.... i have tried different drivers e.i. 9.12 8. something. 10.5 10.7 and same thing. I have tried different bridges. i have tried reversing the cards and same thing. I know both cards work for sure so the problem isnt there. My mobo drivers are up to date. Same goes for my mobo bios. And crossfire is enabled in ccc.

My rig is amd phenom 9600, msi k9a2 cf mobo. 4 gigs 800mhz dd2. cp-850 antec psu(850 crossfire/sli supported). so it shouldnt be a power issue.

I have looked in device manager it shows the card just like ccc, and hwmontior. In the device manager it doesnt show the card having any errors so im not sure what to do. i have post on desktopreview.com. but that led me here.

The only thing i can think of being the problem which i dont know how to fix is 1 of the gpus bios diver date is 2009/02/11 and the other is 2008/10/16. not sure if that would be causing it to be disabled.

Please help thanks a lot any input.

Also the screen looks shaky. when both cards are in.

More about : 2nd 4870 1gb link

September 1, 2010 6:46:18 AM

I got it to link, had to install windows 7 64 bit. It says linked no errors in device manager but its not using the 2nd gpu. only the first is being used i have seen this from the same fps in 3dmarks and starcraft 2, ran gpuz to confirm what do i do at this point ?
m
0
l
September 1, 2010 8:18:22 AM

Hello,

Did you enabled crossfire in Catalyst? Make sure you have checked your options there aswell.

Is the brigde correctly attached?
m
0
l
Related resources
a b U Graphics card
September 1, 2010 9:47:25 AM

Update to the latest motherboard BIO's for your mobo, If it still does work properly I suggest switching the cards around to see if the second PCI-E slot is faulty.
m
0
l
September 1, 2010 5:04:16 PM

My mother boards bios is the highest version that msi has realease. same goes for my mother board drivers. and gpu drivers.

For the cards to say that they are linked the crossfire bridge has to be in right and working, as well as crossfire being enabled in ccc, and ai being turned on.

The computer says that it is working in ccc, and device manager has no errors, and it says that both of the carrds are working. But i know for a fact they arent.

there is no fps gain in any thing i do. also i tested with gpuz and there is no activity on the second gpu.

So i am not sure what to do any more.

Thanks for the replys
m
0
l
!