Sign in with
Sign up | Sign in
Your question

Please Help. Monitor/GFX Card Resolution problem

Last response: in Graphics & Displays
Share
August 31, 2010 3:40:29 PM

Hi all.

Let me start by saying thank you for runnigh this forum. I have fixed many a computer problem simply by consulting tom's hardware. For this, I thank you.

Now, Im having a real headache with my display setup (GFX Card and/or Monitor) that i just can't figure out. This is my PC setup:

Windows 7 Ultimate x64

AMD Phenom 9550 Quad Core CPU
ASRock ALiveNF5SLI-1394 motherboard
2GB Ram

ATI HD 4850 GFX Card 512MB
ViewSonic Q241wb-2 Optiquest Monitor
(Native Resolution 1920x1200)

And Hard Drives, DVD-RW case keyboard mouse etc etc etc.....


Ive had this setup for over a year now and everything worked fine. I kept drivers up to date and my display was always set at 1920x1200 with no problems. However, about 3-4 weeks ago, the resolution dropped down to 1600x1200. I checked the Windows and Catalyst resolution settings and the maximum resolution came up as 1600x1200.

Ive since set the Catalyst maximum resolution options at 1920x1200/60HZ and the option to set this shows up. But when I try setting it to 1920x1200, the image comes up horizontally squashed into the middle three quarters of the screen.

I've tried everything from reinstalling ATI drivers and Catalyst to uninstalling monitor drivers but no joy. The monitor drivers I downloaded were for Windows XP X64, which gave me an error at the end of installation but suggested i manually install the drivers from C:\ViewSonic. I tried this but i got an error at the end saying "Windows cannot find the specified file", even though I went to that directory and could see the files.

Some additional information which may prove useful in solving this problem:

I dual boot Win7-64 and Ubuntu10.04 64 bit and I'm having the same resolution problem in both OS's, which i think points to a hardware issue. Ive used ubuntu with my setup in the past with no problems

In device manager, my monitor always showed up as "Q241wb" before this problem began but now shows up as "Generic Non-PnP Monitor". (I checked the label on the back of my monitor and it actually says Q241wb-2.

My monitor has a vga port at the back and my gfx card has 2 DVI ports. Ive always used the same cable with a dvi-vga adapter. I changed this adapter some time back so I don't know if this may be an issue.

I had a BSOD yesterday, "SYSTEM_SERVICE_EXEPTION". JUST though I wouldd throw that in there



I can't think of any other information that I can give but if there is then by all means request it. PLEASE PLEASE PLEASE HELP!!! Ive been at this for about a month and I'm slowly losing my mind. If I dont play CoD MW2 properly soon then you'll be seeing me on the news in cuffs.

As always, any help is much appreciated.

Craig

P.S. Im a noob forumer poster guy so please don't flame and laugh etc etc.
August 31, 2010 5:09:26 PM

Excuse the spelling mistakes please. Just reread my post.

And ummm.... bump
Related resources
September 2, 2010 12:38:41 PM

sigh.......bump
a b U Graphics card
a b C Monitor
September 2, 2010 1:14:46 PM

Try a different VGA cable or DVI-VGA adapter.
September 2, 2010 6:09:49 PM

Hi Skolpo

Ive tried a different cable and it didnt make a difference.

I'm getting a different adapter in a couple of days so i'll try that. However, I've googled this and couldnt find any information regarding resolution limits on DVI-VGA adapters or different types of them. Perhaps mines faulty.

Anyone know if theres different types of adapters? While i'm waiting for my new adapter to get here, anyone got any idea what else might cause your resolution to suddenly be limited to 1600x1200?

Thanks
a c 125 U Graphics card
a b C Monitor
September 2, 2010 9:48:47 PM

It really sounds like monitor driver issue...

Download Driver Sweeper and Ccleaner. Uninstall ATI drivers, monitor drivers, and everything related to those. Run Driver Sweeper to completely clean them. Run Ccleaner to sweep the registry.
Reboot.
Install ATI drivers, and then install monitor drivers it isn't working at that point.

Have you tried using older ATI drivers?
a b U Graphics card
a b C Monitor
September 2, 2010 11:23:12 PM

It could very well be the adapter since it fails to work on different OS's. You can always test it on another monitor to see if it might be a faulty monitor. My guess is the adapter, but if it isn't, testing a different monitor or video card will allow you to isolate the issue.
September 3, 2010 12:44:14 PM

Sounds like a plan. I should be getting another adapter today. I'll let you know how it goes.

Thanks
September 3, 2010 12:48:08 PM

Sorry Wolf, didnt see your post.

Ive tried uninstalling drivers to no avail. I hadnt pursued the driver possibility much further as the same problem was exhibited on different OS's so I guess that almost rules out a software issue.

As mentioned above, I'll be trying a different adapater today. I'll try the Driver Sweeper and older drivers (already use CCleaner)as well and see how that go.

Thanks for the help guys. Muchos gracias.
September 3, 2010 8:03:49 PM

Fixed the problem. Turns out it was the adapter. I looked at the two and they have completely different pin setups, which I didnt know. Must be different types.

Thanks for the help all. Much appreciated.

Ummm....... how do I mark this as solved???
a c 153 U Graphics card
a b C Monitor
September 3, 2010 8:33:51 PM

Go to the post that helped you the most and click "best answer" on their post. Which I think would be Skolpo's last post.
!