Sign in with
Sign up | Sign in
Your question

Bios detecting my HDDs, but some not showing in My Computer/Windows Explorer

Last response: in Storage
Share
January 26, 2013 2:48:55 PM

Hello,
My comp config is as follow:
Gigabyte GA-EX58a-UD3R motherboard, tripple channel Corsair 3x4gb, Patriot 240gb SSD for the OS, Windows 7 Ultimate 64 bit, i7 920 2.67GHz, brand new 650W Power Supply (Muscle Power, I just bought it few days ago), NVidia GeForce 9800GT Video Adapter, Pioneer DVD-RW ROM Drive.
All of my data are stored in Hitachi DeskStar Sata 3 2TB either 5400RPM or 7200RPM. But some of these HDDs are detected by the Bios (when as internal HDD) but not showing in My Computer/Windows Explorer (It appears in Device Manager and Safely Remove Hardware and Eject Media) which caused me couldn't access my video file stored on those HDDs.
A week before, everything is running well and for some certain unknown reason, it doesn't work (I just realized the problem when I eschanged my HDD in HDD Docking). This happens when the HDD is connected as internal drive, as well as through HDD docking. I've check the HDDs which couldnt show up in My Computer by taking it and install it in another computer (i3 Proc. based desktop) as a second drive and it works fine.
At the same time, I also unable to access my Samsung Mini External HDD (120GB, 160GB) with the same symptom as mentioned above.
I've ever tried to disable, Uninstall the driver, scan hardware change through Device Manager, but couldn't solve my problem.
For the last few days, I tried to fresh install Wins7 Ultimate 64 bit on my brand new Hitachi Deskstar 2TB Sata3 HDD, experienced few times blue screen and never succeed till now. There is no temperature issue, since I opened up the casing and added 1 small AC Fan to help cool down my comp. In the casing, I've 3 x 12cm cooling fan, 1x8cm cooling fan and 12 cm cooling fan inside the Power Supply. PC's interior is cleaned regularly.
May I ask someone out there to assist me in solving my problem?
Thanks a lot in advance,
a b G Storage
January 26, 2013 8:30:19 PM

When you bought the new PSU, did you buy that because the old one blew up? Has the problem occured since you installed this new PSU. I have not heard of that brand and sometimes just because it says 650W doesn't mean it is 650W. If you have your old PSU can you try and reconnect it and test as it sounds like you have tried quite alot to get it working.
m
0
l
January 28, 2013 12:18:06 AM

The old PSU which is Corsair CMPSU-550VX automatically shut down after the message of the m/b displayed on the monitor, I waited for a while and then tried to turned on again for several times with the same results. My problem seems to be intermittent problem before that with some of the HDDs couldn't be accessed. My friend lend me an ACBel 510W PSU before I finally bought my own, I heard the brand is the OEM of Seasonic PSU. It has been tried with the ACBel PSU before the new one. The Corsair and the comp is nearly 3 years old and is on for about 15 hours each day because I do alot with video editing, that's why my HDDs average is 2TB in size.
Yesterday I brought in a brand new Hitachi Desk Star 7200 rpm 2TB hdd and I'm still struggling in installing 64 bit Win 7 which didn't happen in the past.
I hope this additional information useful for you in assisting me to fix the problem.
Thanks in advance.
m
0
l
!