Sign in with
Sign up | Sign in
Your question
Solved

Cannot boot from my hard drive after set RAID by accident

Last response: in Storage
Share
January 27, 2013 5:04:18 AM

Hi,
I am trying to set a RAID1 for my two non-RAID hard disks(one is empty one is my data with operation system). I did not backup my data. In the intel bios setting tool( ctrl +I to enter), I choose to create a RAID 1 volume. After that I all my disks is not bootable. I know above is not a correct way to set the RAID 1, but it is too late.
I just want everything goes back, get my data back , any ideas?
The only thing I do is : plug in a new empty hard drive to my computer, then use the bios tool created a raid1 volume. That is all.
Can I still get the data back on the hard drives?
Thanks!

Best solution

a c 79 G Storage
January 27, 2013 5:56:36 AM

Install the affected drive into another PC and use partition recovery software:
http://www.easeus.com/partition-recovery/
Share
January 27, 2013 1:05:28 PM

I will try that. I guess the bios program just delete the MBR in my disk.
m
0
l
Related resources
a c 359 G Storage
January 28, 2013 12:50:00 AM

There might be an easier way. The root of the problem is that you converted your only HDD into a RAID1 array. BUT Windows does not have any "built-in" driver for a RAID1 array, and hence it cannot access the HDD's of that new array to boot from. If you were doing a complete fresh install of Windows to a RAID1 array, there is a process for installing the required driver as part of the Install. But I don't know of a good way to do that for an OLD installed Windows. Maybe someone else can offer guidance on that.

HOWEVER, your immediate problem is that you can't boot from the RAID1 array. Now, you Created that array using CTRL-I to enter the Intel RAID Management utility. If you read the manual on this system, I bet that, in that same set of tools, there is a process to Break the RAID1 array back down into two independent non-RAIDed disks. Follow that and you'll be back to separate HDD's that Windows DOES know how to use, and you should be able to boot up again without the RAID array.
m
0
l
January 28, 2013 7:14:40 AM

Ok! You could try a special partition recovery tool called Vimx Partition Recovery, which can fix the damage, undo changes on MBR and restore the partition as MBR of a partition is damaged by virus, or changed by human.

Download it: http://www.vimxsoft.com/partition-recovery/

Important note: You should always keep a backup of your important data in the future.
m
0
l
a c 383 G Storage
January 28, 2013 11:33:15 AM

You can't make a boot drive part of raid after windows (the OS) is installed. You need to create the raid array, then install windows onto it.
m
0
l
January 28, 2013 3:11:15 PM

Best answer selected by ygxyvesuvius.
m
0
l
January 28, 2013 3:21:13 PM

Thanks everyone for the information! The problem is solved using a whole day time.
First I use the bios tool intel matrix storage manager to set my disks to non-raid.
Then I use a ubuntu live cd to boot the computer, through it I installed a testdisk tool to find the partitions(have to use deep search, very long time). After the recovery of the partition table all the data on the disk is recovered and can be read under the live CD system. Finally, I use system installation cd to recovery the bootloader, so everything goes back.
I think the bios based intel matrix storage tool is very basic, it is only useful when you want to config a complete new raid array without keeping the data.
In order to change the non-raid disks to raid 1 without losing the data, you have to use the soft: intel rapid storage technology under windows(I think linux is also fine to run after raid is all setup, and you just cannot config raid under it).
m
0
l
a c 383 G Storage
January 28, 2013 3:54:44 PM

ygxyvesuvius said:

I think the bios based intel matrix storage tool is very basic, it is only useful when you want to config a complete new raid array without keeping the data.


This is how most all RAID works. Creating a RAID volume almost always destroys all data on the drives. Your either need to configure RAID before you put data on the drives, or backup all the data, create the RAID volume, then restore the data onto the RAID volume.
m
0
l
!