Hard Drive keeps disconnecting & seems slower

First off, I have an SSD, 60gb OCZ Vertex 3, that i use primarily for Windows 7, Firefox, and the other things I deem essential. Everything on there seems to be running fine, nothing out of the ordinary.

While on the HD, Seagate Barracuda 7200 rpm 2tb, everything seems to have gone to oblivion. Sometimes I can run this thing, I am able to run and play Guild Wars 2, but it seems a bit slower to load when I log in. Then there are times when it completely disconnects from my computer. When I launch Steam, it wouldn't or even log me in. After that, the HD drive would disconnect with my Intel Rapid Storage Technology saying that it has been removed or something. Plus when I open Intel Rapid Storage Technology, it would say that the port is empty.

Right now I am totally lost and unsure what happened to my HD or know how to fix.
2 answers Last reply
More about hard drive disconnecting slower
  1. If the Seagate hard drive is not your Windows boot drive, test it with SeaTools for Windows (SeaTools for Windows must be installed on the SSD, not on the hard drive you want to test): http://www.seagate.com/support/downloads/seatools/

    (URL not available when I just tried - hopefully it's only a temporary glitch)
  2. phil22 said:
    If the Seagate hard drive is not your Windows boot drive, test it with SeaTools for Windows (SeaTools for Windows must be installed on the SSD, not on the hard drive you want to test): http://www.seagate.com/support/downloads/seatools/


    Thanks for the help, seems like I need to replace it now.
Ask a new question

Read More

Hard Drives Storage