Sign in with
Sign up | Sign in
Your question

Possible VGA issue?

Last response: in Graphics & Displays
Share
September 2, 2010 11:47:50 PM

Recently I have been noticing that my computer is crashing whenever playing certain kind of games such as Starcraft 2 and Mafia 2. For some reason I would get an error message from Windows saying there was a problem in the program and needs to shut down. So back to desktop and I try to play an .avi file but it doesn't render correctly sound playback is messed up and i get either myraid of colors playing on the video or random lines running though it. Then i restart the comp and everything gets reset to normal. Weirdly this only happens with my newest games and not with my old ones such as Left 4 Dead and Team Fortress 2.Run those for hours without crashing while running SC2 or Mafia 2 I crash anywhere between 5 - 10 minutes. At first I thought it was because of the video card and its overheating or perhaps a CPU issue but I check and all temps were nominal. GPU temps ran about 50 C to around 55 C idle and 70 C under load. CPU stayed at a constant 35 C and 45 C tops under load. Hard Drive diags came up clean. I keep the tower clean and dust free so I am at a loss at to explain why my games keep crashing.
Here are my sys specs:
MSI 890GXM-G65 Mobo - purchased less than 2 months ago
AMD 955 3.2 GHz Black Edition - purchased less than 2 months
Corsair 4GB DDR3 XMS3 10666 - also less than 2 months old
Diamond HD 4870 512 MB - over 2 years old
Seagate Barracuda HDD - 500GB 7200 rpms SATA - brand new
Coolmax 700W PSU Crossfire Ready (Modular)
Windows 7 Professional x64 - OS

Cooling of the tower is more than sufficient I am paranoid about heat so I got 4 120 mm fans, Coolmaster Hyper 212 Plus with Dual 120 MM fans, also got some VGA blowers mounted underneath, and some HDD fans for my Seagate drive.

Drivers are fully updated (first thing I checked) along with Direct X and PhysX drivers. Also ran numerous scans Spyware/Virus in the off chance it was them affecting it. Even gave reg cleaners a shot but didnt seem to do anything in terms of performance. Comp is still running fast and games can be run in High Settings but its just those two games that keep crashing on me. I tried lowering settings and numerous other tweaks to make the game run but all ended in a failure. (Also as a side note, yes I bought those games from EB games and Steam..No pirated software for me)

Here is the windows error i received
Description
Faulting Application Path: C:\Program Files (x86)\2K Games\Mafia II\pc\Mafia2.exe

Problem signature
Problem Event Name: APPCRASH
Application Name: Mafia2.exe
Application Version: 1.0.0.1
Application Timestamp: 4c6d595d
Fault Module Name: Mafia2.exe
Fault Module Version: 1.0.0.1
Fault Module Timestamp: 4c6d595d
Exception Code: c0000005
Exception Offset: 0025cf8f
OS Version: 6.1.7600.2.0.0.256.48
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789


So yeah I am unsure if its a hardware or software issue but for it to happen numerous times in the newer games leads me to think that it might be because my VGA is dying but I can be wrong. Hopefully you can all help me fix this problem. Thanks in advance!

More about : vga issue

September 3, 2010 4:46:31 AM

What happened about the other games?
Crash as well? or just happened on Mafia and starcraft?

Try your card in different PC, if the same problem appear then your card is going bad...
m
0
l
September 3, 2010 6:37:39 AM

If you don't have another PC, can you try a friends PC, or maybe borrow a friends GPU? I am not sure how long a GPU is supposed to last but it could very well be a likely problem.
m
0
l
Related resources
September 3, 2010 6:42:36 AM

Just on Mafia and Starcraft I think its going bad just bought a new HD5830 and hopefully that solves the problem but i rather like my HD 4870 so sad
m
0
l
September 3, 2010 7:27:28 AM

Have you also tried re-installing the games ?
m
0
l
September 3, 2010 5:52:29 PM

Yes I have actually, on a whim I even loaded up my back up partition drive with a fresh copy of Win 7. Installed off there but the crashes still occur.
m
0
l
!