Sign in with
Sign up | Sign in
Your question
Solved

AHCI Drive Init

Last response: in Components
Share
January 18, 2011 9:37:18 PM

I have a Gigabyte mobo, model GA-MA78GM-US2H and 2 SATA hard disk (320 GB WD and 500 GB WD).

In the 320GB HD I have installed te OS (Windows XP SP3 updated) and the SATA MODE in BIOS is setting to AHCI.

At moment to boot, the BIOS show a message "AHCI DRIVE INIT" and later show the XP booting screen (freezed) during a 3 minuts aprox. After that time period mentioned, the load of Windows XP continue and the computer works perfectly well.

Any suggestions?

More about : ahci drive init

January 19, 2011 7:25:59 AM

Does this happen every-time you boot into XP or then was it a one time thing?
m
0
l
January 19, 2011 1:31:16 PM

Every time, but last night I found the solution.
In the BIOS, disable USB legacy, because it seems that was looking for a USB device to boot.
m
0
l
Related resources

Best solution

January 20, 2011 5:53:40 AM

I wouldn't suggest doing that, by disabling USB Legacy you will disable USB support for all Legacy devices.....:) 
Usually when we make a rig, we disable the Boot from other devices, just leave the HDD and Optical drive in the first 2 slots.
If you have something (hdd, flash drv) always plugged into the USB , that ain't a very good idea......
And once the system if fully functional as you want it, then the BIOS is changed and the boot setting are set at the HDD disabling all other options.....
Saves on boot up time by a few seconds..... even resources for the IE1394 or firewire things are disabled since we never use them or plan to.

Anyway, I'd suggest leaving that on and disabling the Boot sequence and just leaving it to you Primary boot device
Share
January 29, 2011 11:09:55 PM

Let's see, I disable in BIOS the "Legacy USB storage detect" option. My USB devices are working properly because the "USB EHCI Controller" option is enabled.
My problem was that Windows XP was freezed while looking for a USB device to boot. Turning off this option, Windows starts normally without problems.

The problem has been solved.
m
0
l
February 9, 2011 10:39:04 AM

Best answer selected by Steinhaus.
m
0
l
!