Sign in with
Sign up | Sign in
Your question

HAVE 8GB RAM INSTALLED-ONLY SEEING 4GB w/WXP64b

Last response: in Memory
Share
September 19, 2011 10:49:47 AM

Good evening, i have a problem, i have installed at my computer 8gb ram but the system sees only 4gb ram
and i do not know why, i have asus p5q ( not Pro ) motherboard and i searched if is bios firmware problem and i didn't find anything.
If anyone knows please tell me how can i fix it!!!

Thanks in advance
September 19, 2011 11:28:49 AM

m8 of mine had exact same problem last week, all we did was remove the ram to 4gb, then 2 gb, went thru all the sticks, found none faulty, put them all back in together, booted up & hey presto, 8gb showed, doesnt really help I know but just in case, try the same, annoying to do lots of boots but if it works then gr8
September 19, 2011 1:46:55 PM

Yeah you might want to try and reseat your ram.
Related resources
September 19, 2011 4:55:15 PM

make sure you set the correct voltage most of the time located on the the ram stick itself example:(  cas 8-8-8-24) this is stepping and then read example:( 1.65v) this is the voltage.
After finding this writing on the ram sticks copy down on a piece of paper go into the bios of the computer under something to the effect of computer settings,not hard drive,fan speed,bois reset,safe bios boot,etc. go to the title memory enable the auto function to set stepping manually should allow the ability to further scroll down on the page find the four seperate lines of text that represent each of the the main steps in the cycle of the memory. Reset value of each with transfering the numbers wrote on the paper in order left to right on the paper via up to down on the bois settings for memory. Then while you are in the bois go to voltages find memory voltage transfer the voltage number you also copied down on your piece of paper and apply that in the memory voltage area that said auto.
a c 347 } Memory
September 19, 2011 5:16:45 PM

There are several 'P5Q' models, so I've posted an example. Further. if you mix-matched RAM then the BIOS can indeed turn-off some of the DIMM slots.

Q - What exact OS do you have installed e.g. XP SP3 32-bit.
Q - What exact set(s) of RAM; please provide a link.

P5QL ref - http://usa.asus.com/Motherboards/Intel_Socket_775/P5QL/...
Memory 4 x DIMM, Max. 16 GB, DDR2 1066/800/667 Non-ECC,Un-buffered Memory
Dual Channel memory architecture

1. 64-bit OS is required >4GB otherwise yes all you'll see is 4GB
2. BIOS:
Memory Remapping Feature -> Enabled ; 64-bit
3. Uncheck Maximum Memory from MSCONFIG
September 19, 2011 5:18:13 PM

First of all, check how much RAM sees your BIOS, then you'll know if it's the OS who don't see the memory, or it's not presented on a system hardware level and you'll know where to look for the solution.
September 20, 2011 2:19:12 AM

It's probably your OS. If it's not 64 bit then you can only use and see 4gb of ram
October 8, 2011 5:18:27 PM

setting the ram speed also. Well I have found with most memory your not gonna get the respective speed that is listed on the ram stick. Ya have to set it lower most of the time not because the ram is bad; but because the motherboard ram combo does not work as good as the ideal situation listed. So setting the ram speed to high will cause a error of not reading all the memory. Try setting voltage higher if you want the ram speed your at with a increase of millivolts on the memory lanes between the processor and memory if you have them. If you do have a millivolt setting for the memory lanes their should be four ajustment setting in a independent section in the voltage ajustment section close the bottom. With that in mind try also bumping or raising the voltage in the first lane then the third lane leaving the other lanes on their auto settings.
!