Sign in with
Sign up | Sign in
Your question

Can't enable physx on Dark void (GTX 470)

Last response: in Graphics & Displays
Share
September 6, 2010 4:20:22 PM

Hi
I got Dark void game , tried to set physx to high , but it's locked only to low !!
How can I set it to high ? , I 've the latest physx driver and tried re-installing it but the problems remains !!

Thanks
a c 171 Î Nvidia
September 6, 2010 4:26:23 PM

Add a secondary card and dedicate it to the PhysX workload.
September 6, 2010 5:13:45 PM

Mousemonkey said:
Add a secondary card and dedicate it to the PhysX workload.



That doesn't make much sense... Dark Void is by no means a graphically intense game. I ran it on my 9800GX2 with physics on high and 1280x1024 with all graphics on high. If a 9800GX2 can run Dark Void at max resolution with physics on high then a 470 should have no problems, even without 2 GPU's... the Fermi architecture should be more than adequate enough for Dark Void, because that's what it was optimized for.


I've got a GTX 470 coming in the mail, I should be able to comment about this once i get the card installed.
Related resources
a c 171 Î Nvidia
September 6, 2010 5:15:53 PM

jackcrackerman said:
That doesn't make much sense... Dark Void is by no means a graphically intense game. I ran it on my 9800GX2 with physics on high and 1280x1024 with all graphics on high. If a 9800GX2 can run Dark Void at max resolution with physics on high then a 470 should have no problems, even without 2 GPU's... the Fermi architecture should be more than adequate enough for Dark Void, because that's what it was optimized for.

Except that the game is coded to see the second GPU hence why your 9800GX2 worked.
September 6, 2010 8:44:29 PM

I see, so these games will not allow hardware accelerated physx unless you have a dedicated GPU for it.
a c 171 Î Nvidia
September 6, 2010 8:46:00 PM

jackcrackerman said:
I see, so these games will not allow hardware accelerated physx unless you have a dedicated GPU for it.

Not all them perhaps but this one in particular might be coded that way.
September 7, 2010 4:25:44 AM

Now this pissed me off , 300$ card and the game is locked , I think there might be some type of patch or crack which can change the code to make it allow one single gpu for High physx .True or false ?

I'll wait for you jackcrackman , When you get your card , try it and tell me what happened ?
a c 81 Î Nvidia
September 7, 2010 5:27:12 AM

Doing a search on benchmarks for that game, and I ran into this: http://physxinfo.com/news/1657/dark-void-physx-benchmar...

It does seem that you have to have a dedicated physX card in order to go beyond low settings, and it is officially recommended that you have at least a dedicated GTX260 doing physX in order to use high settings.
September 7, 2010 7:18:39 AM

r_Rozx said:
Now this pissed me off , 300$ card and the game is locked , I think there might be some type of patch or crack which can change the code to make it allow one single gpu for High physx .True or false ?

I'll wait for you jackcrackman , When you get your card , try it and tell me what happened ?



I agree with you, would be quite lame if they made it so you need to dedicate a second GPU to physx. Either way I'm looking at getting a cheapo 260GTX to add as a dedicated Physx GPU in the near future... sigh, always a work in progress I suppose.
September 8, 2010 7:39:56 PM

260 Gtx is not a cheapo card , You need also to buy a new PSU , You also need to modify the case to get better air flow , the total cost will be of no value for physx specially that the Gtx 470 is doin very good with high physx on other games .
Dark void doesn't deserve buying a new GFX card .I'm done with this game .

In the future when the gtx 470 is cheap , I'll buy another one then .I don't need to buy another one now as one is enough for current games .
August 2, 2011 3:05:59 PM

Digital copy (from Steam, NZONE, etc) of Dark Void:

1. Make sure you have the latest NVIDIA drivers
2. Install the game, Dark Void.
3. Here is the manual fix:

For Vista/Win7
Spoiler
In the Control Panel select Programs and Features
Right click on "NVIDIA game system software 2.8.1" and select 'Uninstall'
Right click on "NVIDIA PhysX" and select 'Repair'


For XP:
Spoiler
In the Control Panel select Add or Remove Programs
Click on "NVIDIA game system software 2.8.1" and select 'Remove'
Click on "NVIDIA PhysX" and click on 'Click here for more information.' Afterwards click on 'Repair'


Retail copy of Dark Void:

1. Make sure you have the latest NVIDIA drivers
2. Install the game, Dark Void.
3. Install the Dark Void PhysX patch (adds PhysX Effects into the game), located here
4. Do this manual fix:

For Vista/Win7
Spoiler
In the Control Panel select Programs and Features
Right click on "NVIDIA game system software 2.8.1" and select 'Uninstall'
Right click on "NVIDIA PhysX" and select 'Repair'


For XP:
Spoiler
In the Control Panel select Add or Remove Programs
Click on "NVIDIA game system software 2.8.1" and select 'Remove'
Click on "NVIDIA PhysX" and click on "Click here for more information." Afterwards click on 'Repair'
!