Sign in with
Sign up | Sign in
Your question

Hard Drive Issues and Data Loss. Please Help!

Last response: in Storage
Share
February 3, 2013 4:07:01 PM

Hello,
I have been having issues with my Toshiba 640 GB USB 2.0/eSATA Desktop External Hard Dive PH3064U-1EXB, working on a Macbook Mac OS X Version 10.6.8 Processor 2.4 GHz Intel Core Duo Memory 2 GB 1067 MHz DDR3 Startup Disk Macintosh HD and a Windows7 partitioned on part. I am in no way an expert.

The hard drive is unreadable, unpartioned(now) and the data is extremely valuable so i need to figure out how to fix this with out loosing the data. When mounted my computer says Disk Inserted is Unreadable and on windows it says similair and that it may be corrupted.

The hard drive was refurbished when I bought it and I have had small issues here and there since. It would have a problem ejecting but it always showed back up when mounted again. (It might have been the cable) Then, it wouldn't let me copy files to and from. I repaired the disk and it ran fine for a while. After awhile, it had the same issues with copying again and right away with ejecting issues, as a result I believe it wasn't ejected properly. When I plugged it in again, My computer says Disk Inserted is Unreadable and on windows it says similair and that it may be corrupted. It didn't show up in my computer and disk utility didn't give me the option to mount. The message that came up said eject, ignore, initialize at the bottom. I was told in a forum that the computer wont work with the drive untill it was initialized. So after trying every basic available options I hit the initialize but it didn't do anything. I did not reformat or erase as I know these things will ease my data.


I'm not sure if this so far has caused the problems but to move forward I skimmed through countless forums to where there was no one with all the same issues as me.


I bought a hard drive enclosure hoping it was the casing's issue but I came up with the same messages and still didn't mount. In windows I tried disk management and it showed all the drives and just like in disk utility it showed toshiba but as 2TB drive and not 640 GB anymore. Then in Diskdrill it showed it as 2047gb unallocated space. I'm sure that means it needs to be reformatted but again I don't want to loose the data. Also It shows that it is now Unpartitioned.

In Diskdrill I tried to recover data and just like in a couple other programs it stayed at 0% for a long time, and I wasn't sure if this was normal (If someone could enlighten me) so I moved on.


I read that in Mac you can partition without loosing data in Disk Utility so I figured that should be my first step. I went to Disk Utility and the only thing that shows up for the external hard drive is Toshiba TB when it used to have under that the 640GB drive. I've Uploaded a Snapshot. So Selected one Partition and left the format and capacity as it was and selected apply, I get this : Partition failed with the error:
POSIX reports: The operation couldn’t be completed. Cannot allocate memory

I tried Freezing The Hard Drive. It showed no re.sults at all

Through Test Disk and Disk drill and a couple others it has remained at 0% (one of them couldn't even find it (MaybeDiskwarrior) but I'm going to go ahead and keep it scanning for as long as I can; I have about nine hours. I will let you know my results

Untill then, can someone please offer me some insight. Whats gone wrong with this thing and how to fix it >_<

Thanks in advance.

!