Solved

New build will not start

Hi i just put together a new computer and It wont boot up, when i plug in the power supply the green LED on the motherboard turns on but when i press the power switch nothing happens. It turns on when the 12v atx cord is unplugged but when i plug it back in nothing happens, a soft squeek comes out and other than that nothing happens. I have reinstalled all hardware twice and followed the guides but it still wont fire up. Here are my specs


ASUS M4A87TD EVO AM3 AMD 870 SATA 6Gb/s USB 3.0 ATX AMD Motherboard
GIGABYTE GV-R685D5-1GD Radeon HD 6850 1GB 256-bit GDDR5 PCI Express 2.1 x16 HDCP Ready CrossFireX Support Video Card with ...
SAMSUNG Spinpoint F3 HD103SJ 1TB 7200 RPM SATA 3.0Gb/s 3.5" Internal Hard Drive -Bare Drive
AMD Athlon II X4 640 Propus 3.0GHz Socket AM3 95W Quad-Core Desktop Processor ADX640WFGMBOX
Rosewill CHALLENGER Black Gaming ATX Mid Tower Computer Case ,comes with Three Fans-1x Front Blue LED 120mm Fan, 1x Top 140mm .
OCZ Fatal1ty OCZ550FTY 550W ATX12V v2.2 / EPS12V SLI Ready 80 PLUS Certified Modular Active PFC Power Supply
LITE-ON 22X DVD Writer Black IDE Model iHAP422-98 LightScribe Support
Corsair 2x2G DDR3 1600 XMS3 CMX4GX3M2A1600C9

Not sure what to do now.....
Thanks
4 answers Last reply Best Answer
More about build start
  1. Best answer
    ^ You went through this right ?
    http://www.tomshardware.com/forum/261145-31-perform-steps-posting-boot-video-problems
    Followed all the steps without skipping any ? Did breadboarding ?
  2. Best answer selected by akaaron.
  3. Solved, i had the ATX 12v in wrong, i feel dumb.
    Thanks
  4. ^ Nice that its solved,....Have fun...
Ask a new question

Read More

New Build Systems