Sign in with
Sign up | Sign in
Your question

WD My Passport Not accesible

Last response: in Storage
Share
February 5, 2013 11:20:41 AM

Hi All,

I have a WD My passport 1TB external hard drive USB 3.0 powered since Christmas. It's been working perfectly up until yesterday when I plugged it in and it took ages to show up in explorer, but when it did it wasn't accessible and I kept getting the 'need to format' message.

I use this to store many diff files movies, photos etc and I use it in conjunction with my Xbox so it was formatted to FAT32 and partitioned so I could use it on the Xbox.

Anyway it does show in Disk Mgmt and in explorer. But I'm worried as it shows as RAW in the properties digibox and as 100% free in Disk MGMT. ( I have screenshots, how do I post them here??)

I also ran CHKDSK N: /f which crashed out.

I've used this HD with Windows XP and with Windows 7 on my laptop with no probs (till now, !)
I have a lot of files on this that I spent backing up and would love to at least get the files off the hard drive if I do have to format it again.

I hope I've explained the issue but if anythings unclear or you need further info please ask!!
Thanks for your help
Jason


More about : passport accesible

a c 93 G Storage
February 5, 2013 1:09:55 PM

Does this problem occur on more than one computer? Have you tried swapping the USB cable?

Also, you can go to the WD website and download/install/run some diagnostics to verify the health of the drive. You can get those utilities here:

http://support.wdc.com/product/download.asp?wdc_lang=en

Just use your specific model number to get to the downloads for your drive. Good luck!
m
0
l
February 5, 2013 1:53:40 PM

COLGeek said:
Does this problem occur on more than one computer? Have you tried swapping the USB cable?

Also, you can go to the WD website and download/install/run some diagnostics to verify the health of the drive. You can get those utilities here:

http://support.wdc.com/product/download.asp?wdc_lang=en

Just use your specific model number to get to the downloads for your drive. Good luck!


Hi COLGeek,

Yes it happens on my desktop (Win XP) and laptop (Win 7) unfortunately. No I haven't tried swapping the cable yet as one end (external HD end) has a funny looking thin connector on it (I'm sure there's a proper name for it!)
Thanks for the info, I'll try the WD diagnostics and hopefully let you know how it goes tomorrow.

Thanks,
Jason

m
0
l
Related resources
February 7, 2013 8:07:34 AM

Hey,

So I ran the WD diagnostics which eventually failed.
Also ran HD Tune which showed up some bad sectors.
I got the trial version of HDD regenerator which fixed the first bad sector.

Still no access but the drive is visible however in Disk Management under File system is blank??

Any ideas?
Thanks
m
0
l
a c 93 G Storage
February 7, 2013 10:29:53 AM

If under warranty, I would suggest returning for replacement/repair.
m
0
l
!