Sign in with
Sign up | Sign in
Your question

My 5770 with nfs undercover and assassins creed2...gpu usage is far less...:-(

Last response: in Graphics & Displays
Share
September 8, 2010 9:28:34 AM

anyone had any issues with nfs
undercover....for me...all settings
maxed out with full AA @
1280*1024 fps changes from 24
to 64 every now and then making
the game look choppy and not
smooth...:-( then when i look at gpu
usage in afterburner max usage is
54percent !!!! which changes from
25 to 54 every now and then...:-
( am using catalyst 10.8 drivers if
someone has nfs undercover post
ur results...samething happens
with assassins creed2 gpu usage
changes every now and then not
even reaching 80percent!!!! but for
crysis gpu usage is >90 percent
always
September 8, 2010 9:48:41 AM

Do you have the game patched all the way? Try enabling V-syn on and off.
September 8, 2010 9:50:10 AM

Well, tell us your FULL specs:
CPU-RAM-Mobo-PSU-Monitor?
September 8, 2010 10:30:39 AM

budget gaming pc
CPU
athlon 7750 dual core stock@
2.7ghz now@3.29ghz@1.412v
Motherboard
asus m3n78-em
Memory
2gb ddr2 @800mhz @6-6-6-18
Graphics Card
msi 5770 pmd1g@925 core+@
1400 memory
Hard Drive
seagate 500gb sata
Power Supply
zippys 450w 22a on +12v rail
Case
iball case
CPU cooling
stock
GPU cooling
stock
OS
windows 7 ultimate 32 bit
Monitor
lg 20" lcd monitor @1600*900

how do u put ur full pc details at the end of ur post ...wa1???
September 8, 2010 11:24:05 AM

Well,first revert back both your CPU/VGA to stock speeds and check your FPS again,
If it didn't help,then disable Catalyst AI(Catalyst control center> 3D > AI), also is v-sync enabled or disabled ?
September 8, 2010 11:33:44 AM

i tried catalyst ai off it didnt help...vsync is off...i tried at stock also...what is that patch for nfs undercover all the way...?
September 8, 2010 3:07:09 PM

Try with V-sync ON and see if it makes any changes.
Also disable windows "aero" and run the game and see if it helps.
September 8, 2010 3:42:06 PM

thanks a lot maziar....will try it out 2mrw and let u know
September 8, 2010 3:58:46 PM

Need for Speed games are always fickle, you can have the perfect system and it decides not to run smoothly because you changed one setting incorrectly. It took me quite a while to get Undercover looking great and still being smooth.
September 8, 2010 5:15:26 PM

wat is that setting exactly deweycd...??
April 11, 2011 10:04:15 AM

you need more than 22A on the 12v rail on that card the 550 Ti need 24A alone that will be the problem and make sure u have a good cpu cooler to release some stress from the cpu
April 11, 2011 10:29:37 AM

go to amds web site and seach your card then click system requriements the click the Certified power supplies link your wont be on there but you will be able to find a cheap but compatible psu
!