Saitek Eclipse II Keyboard Broken?

I have this Saitek Eclips II keyboard with the three color leds and it doesnt seem to be working.

I've tried plugging it into different usb ports and each time windows makes that sound which to me means "something just got plugged in, but i dont know what to do with it".

I went to device manager and it has a "?" next to the device name, I don't know what to do. Any help is appreciated
6 answers Last reply
More about saitek eclipse keyboard broken
  1. Have you tried right clicking on the ? in device manager and updating driver via windows?

    Otherwise you could try unistalling all usb devices from device manager and re-booting.
  2. I did both of those things before and the LEDs only managed to change colors (that hadn't before) but the keyboard itself still was not working
  3. Double Post. Sorry.

    When updating drivers with windows it can't find a driver
  4. Can you try the keyboard in another machine?
  5. Sorry been busy with other stuff to check posts but yes I have tried it on another machine, Vista 32-Bit (not sure what SP) and it works fine, just an issue with my computer I guess XP 32-Bit SP2
  6. It should work fine, the keyboard shouldn't need any drivers, Windows should find the automatically.

    Have you tried unplugging all other usb devices and just have the keyboard plugged in?

    Try and find anything related to the keyboard inc files and drivers and uninstall it, also unistall in device manager.

    Try running a Windows update with the keyboard plugged in and see if that picks anything up.

    Scan for new devices in Control panel.

    Try updating the driver from device manager and manually select one from the list.

    Thats all I can suggest really.
Ask a new question

Read More

Saitek Keyboards Components