Sign in with
Sign up | Sign in
Your question

Saitek Eclipse II Keyboard Broken?

Last response: in Components
Share
January 22, 2011 5:58:54 PM

I have this Saitek Eclips II keyboard with the three color leds and it doesnt seem to be working.

I've tried plugging it into different usb ports and each time windows makes that sound which to me means "something just got plugged in, but i dont know what to do with it".

I went to device manager and it has a "?" next to the device name, I don't know what to do. Any help is appreciated
January 22, 2011 6:33:18 PM

Have you tried right clicking on the ? in device manager and updating driver via windows?

Otherwise you could try unistalling all usb devices from device manager and re-booting.
m
0
l
January 23, 2011 11:24:47 AM

I did both of those things before and the LEDs only managed to change colors (that hadn't before) but the keyboard itself still was not working
m
0
l
Related resources
Can't find your answer ? Ask !
January 23, 2011 11:25:22 AM

Double Post. Sorry.

When updating drivers with windows it can't find a driver
m
0
l
January 23, 2011 12:07:08 PM

Can you try the keyboard in another machine?
m
0
l
January 29, 2011 9:00:57 PM

Sorry been busy with other stuff to check posts but yes I have tried it on another machine, Vista 32-Bit (not sure what SP) and it works fine, just an issue with my computer I guess XP 32-Bit SP2
m
0
l
January 30, 2011 9:22:12 AM

It should work fine, the keyboard shouldn't need any drivers, Windows should find the automatically.

Have you tried unplugging all other usb devices and just have the keyboard plugged in?

Try and find anything related to the keyboard inc files and drivers and uninstall it, also unistall in device manager.

Try running a Windows update with the keyboard plugged in and see if that picks anything up.

Scan for new devices in Control panel.

Try updating the driver from device manager and manually select one from the list.

Thats all I can suggest really.
m
0
l
!