Sign in with
Sign up | Sign in
Your question
Solved

CD drive listed as disk drive?

Tags:
Last response: in Storage
Share
February 6, 2013 4:57:50 PM

Hey all,

I'm using a custom-built PC (where I got advice for parts here on this very forum! :)  ) - running Windows 7 64-bit.

Recently I had a problem starting my computer, and it was hanging on the "Starting Windows" screen. I cut the power, and launched startup repair and performed a System Restore. After that...

My computer booted up fine. However, now my CD drive is no longer appearing under Windows Explorer at all, although I believe my OS still knows it exists.

I'm using an Asus DRW-24B1ST SATA CD/DVD drive. However, if I open up Device Manager, it's not under CD/DVD Drives, but under Disk Drives as:

ASUS DRW-24B1ST c ATA Device

I've tried Disable/Re-enabling it, Uninstalling and then scanning for hardware changes, using the Microsoft FixIt tool, and looking into the registry to remove the Upper/Lower filter things (which don't exist in my registry).

I really have *no clue* what to do next now, so I've turned here for help. Unfortunately I cannot undo the System Restore as it was done in safe mode, so I'm at a point of no return I feel.

Thanks in advance for all of your help,
SuperXero
February 6, 2013 5:12:11 PM

Unfortunately I've already looked through that thread. :-/ - but yes, that's where I learned to check the registry and also try the fixit tool.

Regarding drivers... I thought the same, but because Windows believes this is a disk drive, I'm unable to install the CD/DVD drivers for it if I try to Update Drivers from device manager and then select that I have the drivers locally.

It most likely is a driver issue I'm guessing, but I can't install them for the CD/DVD drive because it only wants disk drive drivers.
m
0
l
Related resources
a b G Storage
February 6, 2013 5:22:54 PM

Hmm, you made sure those upper/lower filters were not present? If you right click on the drive in device management and go to properties, and then to details, the drop down box should have an option to display the values for those filters. I would assume for you they should be empty if you truly have no values for them in the registry.
m
0
l
a b G Storage
February 6, 2013 5:30:08 PM

Also, you may have been in the incorrect area for the proper registry settings because it is not showing up as the correct type of device. On that same detail drop down take note of the value for Device class guid, then inside of the registry, navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{long GUID presented by that drop down here}, and see if there are upper and lower filters set, and also what some of the other values present (possibly the Class registry value may be incorrect?) I would not go about editing anything yet, just do some quick discovery on it to start.
m
0
l
February 6, 2013 5:36:17 PM

The Device Description says "Disk drive" under the details pane. In the dropdown, I found "Class upper filters" with the value as PartMgr.

However, if I go into the registry and navigate to

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

there are only eight rows of objects.

(Default) - REG_SZ - DVD/CD-ROM drives
Class - REG_SZ - CDROM
ClassDesc - REG_SZ - @%SystemRoot%\System32\StorProp.dll,-17001
EnumPropPages32 - REG_SZ - storprop.dll,DvdPropPageProvider
IconPath - REG_MULTI_SZ - %SystemRoot%\System32\imageres.dll,-30
Installer32 - REG_SZ - storprop.dll,DvdClassInstaller
NoInstallClass - REG_SZ - 1
SilentInstall - REG_SZ - 1

EDIT: Aha! Good catch, the class GUID is the same as above, except the first entry which doesn't end in 965, but 967. I navigated there, the Class is a DiskDrive, but there is an UpperFilters row. Should I remove this?
m
0
l
a b G Storage
February 6, 2013 5:54:41 PM

Take a note of the type/value of the word and go ahead and give it a try, it couldn't hurt. You could also try setting the class to CDROM, I am not too familiar with the registry settings for CD/DVD drives, but the thing does not seem to be working anyways, and I don't think it would screw anything else up to play around with those settings. Just take note of the previous values in case.
m
0
l
a b G Storage
February 6, 2013 5:57:44 PM

And in that other thread it looks like folks had to run the iFixit or whatever after deleting that entry, I would delete the upper filter, run fixit, if that doesn't work I would then alter the Class to CDROM and run the fixit again.
m
0
l
a b G Storage
February 6, 2013 6:02:17 PM

Or even set class to CDROM and try installing the drivers at that point.
m
0
l
February 6, 2013 8:27:26 PM

No good - I removed the UpperFilter, then ran fixit and it was unable to detect it still. However, I'm not sure if I should change the class to CDROM, as both my SSD and HDD have the same GUID as the Asus CD drive now (they're all DiskDrive). Is there any way I can manually change the GUID of the Asus CD drive?
m
0
l
February 6, 2013 8:34:32 PM

By watching the registry editor closer, I can tell which folder it is under the Key. For instance, under the GUID, folder 0008 corresponds to that Asus CD Drive, as when I uninstall the driver for it, it no longer exists, but when I do, I can access that folder.

EDIT: Of course, in the details pane, right under Device class guid is Driver key which tells me the exact same thing.. :sarcastic: 
m
0
l
a b G Storage
February 6, 2013 8:38:57 PM

Hmm, I will look into this again for you in a bit.
m
0
l

Best solution

a b G Storage
February 6, 2013 8:42:16 PM

By chance did you try removing the SATA cable for the drive and reinserting it, or trying another SATA port?
Share
a b G Storage
February 6, 2013 8:46:15 PM

Also, from the couple posts I was able to track down elsewhere, that seems to be a fairly common issue with this specific drive/model. Of course, the guy posted his answer and the parts past the registry info were cut off... but he said Asus quickly identified the issue and resolved it for him. You could try calling them and explaining the issue, I bet they have a fix all ready for this.

There looks to be firmware available for that drive as well, you could see if that will install if the drivers refuse to.
m
0
l
February 6, 2013 9:01:53 PM

I haven't yet tried moving the SATA cable and reinserting it, perhaps I should try that.

I'm waiting to talk with ASUS on their website now - I'll report back if I get anything. Also, I've managed to download the firmware, but it needs to be able to see that the CD drive exists in the first place - and because it's classified as a disk drive, the firmware doesn't see it. I actually can't seem to find any drivers for the CD drive myself online, only the firmware. Interesting.

Thanks so much for your help through this, by the way. Much appreciated :) 

EDIT: They also suggested moving the SATA port. I'll try that soon when I get a chance!
m
0
l
February 7, 2013 11:59:21 AM

This is going to sound crazy, but...

When I woke up this morning, I turned my computer on and it blue screened before it could boot into Windows. I launched Startup Repair and repaired using System Restore. I checked the details, and it said that a driver installation may have created the problem. So after the System Restore, I booted up fine, and... the CD drive is back in the correct place. I was going to change SATA ports later today, but now I guess it isn't necessary.

What a weird problem. Thanks again for your time Chugot!
m
0
l
February 7, 2013 12:00:04 PM

Best answer selected by SuperXero.
m
0
l
a b G Storage
February 7, 2013 12:14:42 PM

Glad you got it squared away at least!
m
0
l
!