Sign in with
Sign up | Sign in
Your question
Closed

External Hard drive asks for format, tried recovery - help

Last response: in Storage
Share
February 7, 2013 4:56:03 AM

I have a Western Digital 500gb sata 16m cache that i have been using as an external drive using a usb to Sata cable. It has been working great for some time, but yesterday, i was using search to find a file on it, and it suddenly made my explorer stuck and crashed. After that, when i connected my drive, it did not let me access my files, and windows started asking me to format it. I didn't try to format it, right now it shows up in my computer, as E:

I have tried a couple of data recovery softwares - namely, R-studio, Easeus and Active partition. R-studio has been the best one for me that worked (randomly), it gave me access to all my files (in the correct folders) after running a scan, and i even transferred some files out before it crashed. I have seen it give i/o error earlier, but not anymore.
I clicked the "Fix MBR (Create typical MBR) in Active, and it seems to have made it able to acces drive a bit. earlier it was giving me a "can not read" errors on all these softwares.

When i go to disk management - it takes a long time to load and shows "Connecting to virtual disk service"
in Easeus. it shows "E:Main Backup (NTFS) 465.75GB and info as WDC WD50 00AAKS-00V1A0 USB Device".
although when i try running intelligent search, it runs for an hour without any result, but shows that it has found Total Files": 110572. NTFS file records: 110572, NTFS boot:1.

When i run checkdisk command from cmd as : chkdsk E: /r , earlier it was giving me "Can not access drive".
Now, it is telling me,
The type of file system is NTFS, windows can't run disk checking on this volume because it is write protected.

My question is, what should i do about this, as all these softwares indicate that my files are intact, i just am not able to access them correctly.

I have a lot of family photos on it, and i promise i'll be more careful once i get them out from this drive, any help is benificial. Thanks.
a c 79 G Storage
February 7, 2013 5:57:16 AM

Could be a faulty SATA-USB cable. Suggest you buy a proper SATA-to-USB hard drive enclosure for it.
And do keep all your valuable data on at least two separate hard drives in future.
Score
0
February 7, 2013 6:11:05 AM

i tried the wire on my other drive, and it works fine. also update: when i try to access from explorer by clicking on the drive, i get error -
E:\ is not accessible
the request could not be performed due to an I/O error.
:( 
Score
0
September 8, 2013 8:42:04 AM

most likely the external drive is corrupted. try to format it.
Score
0
Related resources
!