Sign in with
Sign up | Sign in
Your question

Maxtor OneTouch 4 external drive not working

Last response: in Storage
Share
February 9, 2013 12:20:22 PM

Hello,
Maxtor OneTouch 4 external drive (1T) beeps when connected to my Windows Vista laptop. Laptop doesn't recognize the Maxtor now, either. Have used it without problems for years.

I reinstalled software for it and message said it was successfully installed and device is ready to use. But Vista still doesn't see it. Have shut down, restarted, reconnected, tried different USB cables--everything. No luck.
a b D Laptop
a c 316 G Storage
February 9, 2013 7:51:57 PM

Does it spin up? If not, try a USB Y-cable. This will pick up power from two USB ports.

Otherwise it could be a stiction fault (heads stuck to platters) or a seized spindle motor. Did you drop it or bump it?

Edit: I now see that your drive is powered from an AC adapter, no from the USB port, so please ignore my Y-cable suggstion. Sorry
m
0
l
February 9, 2013 8:22:47 PM

I bumped it slightly--actually bumped the surge protector it's plugged into.
m
0
l
Related resources
a b D Laptop
a c 316 G Storage
February 9, 2013 8:55:23 PM

You could try removing the drive from its enclosure and attaching it directly to a SATA port on your computer's motherboard. This will eliminate the enclosure as a suspect.
m
0
l
February 9, 2013 9:20:34 PM

I'm afraid to do that--but thank you for the advice. I will probably take it to be looked at, then. I hoped that something less frightful than taking the enclosure apart would work to restore it. But that seems doubtful.
m
0
l
February 9, 2013 9:48:30 PM

Hi, Kathleea.

It could be any of a number of things, but perhaps you can do some simple troubleshooting. Does yours have an AC adapter cord? If so, then what follows could help.

I have four Maxtor OneTouch III units, and one by one the power brick (AC adapter) failed on each one. Since there was another drive around it was simple to borrow the AC adapter from another. Fortunately when the other power brick was connected, the drive came to life again.

Another fortunate finding was that the power brick for that model is the same as the one used for many LCD monitors. Amazon shipped another one quickly, and everything was great again. Of course, if this turns out to be the problem, please verify the nameplate polarity and voltage and wattage of the replacement adapter. The label on the power brick will tell you these things. Mine was a 12V, 2.5A adapter with positive polarity on the inside of the plug. This is a common AC adapter that costs less than $10 to replace, so it was not worth the trouble to swap the damaged capacitor inside the power brick. (It's okay to use a replacement adapter with a greater power (wattage) rating than the original adapter, but the voltage, polarity, and plug size of the old and new adapters must match.) I hope the problem with your drive is this simple to fix.
m
0
l
February 10, 2013 11:03:39 PM

Thank you. I hope so, too. As soon as I get a new adapter to test on the drive, I'll find out.
m
0
l
February 11, 2013 2:31:50 AM

kathleea said:
Thank you. I hope so, too. As soon as I get a new adapter to test on the drive, I'll find out.


If you have a spare LCD monitor around, the power adapter for that monitor might have the right voltage, polarity, and plug size. This could help just to test it and see if the AC adapter is the problem.

For the OneTouch III drive, the Kinamax AD-LCD12 adapter was a good match even though this Kinamax adapter has greater wattage (capacity to deliver current) than the original one. There are dozens of similar adapters available on ebay & Amazon.
m
0
l
!