Sign in with
Sign up | Sign in
Your question

Biostar not recognizing Samsung SATA Drive

Last response: in Motherboards
Share
September 25, 2011 10:26:02 PM

Hello everyone,

This is my first post here at Tom's... been an avid lurker for a while and alas, I couldn't find anything that was able to answer my question (at least more specifically than what I did find)

The Scenario:

I recently upgraded my mobo from my old budget gaming rig from a Foxconn A74ML-K to the BIOSTAR A870U3 to upgrade my ram. I am keeping all other parts constant, and I intend to format my hard drive and install Ubuntu 11.04 on my HD (from Win XP... served me well, but time to move on).

The Problem:

For some reason, the BIOS in the new mobo just does not recognize my HD. It is a 500gb Samsung HD502HJ. It was completely compatible with my old mobo and as far as I know it didn't just break from me swapping mobos (I didn't even take it out of the rack on my case). I have isolated it to being an issue with either:

a) Drivers for the mobo

or

b) The HD somehow was bricked by me unplugging and then repugging in the SATA cable.

Choice b) seems much less likely in my opinion. I know it is not an issue with the SATA cables/ports either, since my SATA optical drive is detected normally, and I can even boot to the Ubuntu disc I created. I have tried 4 different known good SATA cables as well, all to no avail.

The Question:

I guess my question is this: What am I missing here that I should be checking to make sure everything is working properly? There is no jumper on my HD (it didn't come with any :??:  ), and I don't have another system to test and make sure the drive is still good. It is the only HD in my machine, so there is no issue with RAID controllers or anything going crazy there. The only thing I have not tried is to make sure the BIOS is up to date for the mobo.

Thanks in advance... I know someone has had something like this happen, and hopefully they were able to solve it!
Randy
a b V Motherboard
September 26, 2011 1:06:17 AM

Have you tried all 6 ports on your board to see if it would be recognized?
If so, try clearing your CMOS, then try every port (starting with SATA1) again.
m
0
l
September 26, 2011 3:04:22 AM

Thanks for the suggestions.

I cleared the CMOS, and then tried a known good port (the SATA port that my optical drive was connected to) and it is still not recognized as having a device connected.

I am starting to wonder if there might be a problem with the drive. That, or this mobo seriously disagrees with SATA HD's

Any other suggestions?


Edit:

Here is my entire system set up in case this helps at all:

AMD Athlon II x4 @ 2.8GHz (http://www.newegg.com/Product/Product.aspx?Item=N82E168...)
Biostar A870U3 Mobo (http://www.newegg.com/Product/Product.aspx?Item=N82E168...)
8GB DDR3 Corsair Vengeance @ 1600MHz (http://www.newegg.com/Product/Product.aspx?Item=N82E168...)
500GB Samsung HD502HJ @ 3.0 GB/s (http://www.newegg.com/Product/Product.aspx?Item=N82E168...)
Sunbeam 580W ATX PSU (http://www.newegg.com/Product/Product.aspx?Item=N82E168...)
512MB DDR5 Sapphire GPU (http://www.newegg.com/Product/Product.aspx?Item=N82E168...)**

**Not the exact model, but close enough... same specs
m
0
l
Related resources
a b V Motherboard
September 26, 2011 3:14:35 AM

See what other Forum members suggest, but yes, I think you have a failed drive.
m
0
l
September 26, 2011 4:15:46 AM

Hmm, well hopefully someone else has some magic that we haven't thought of so far
m
0
l
October 3, 2011 12:45:21 PM

I have the same board and it comes with two yellow SATA cables. I thought I had this problem as well and tried using an old cable that I had lying around for an additional HDD that I wanted to use in this rig. It turns out that the board didn't like my old cable for the drive I was trying to spin up. After I switched it to the native cable that came with the board it started up. Go figure. Could there be a difference between SATA 6/g and SATA 3/g (or lower) cables? The board proved finicky in this way when booting up in AHCI mode but was more lax in regular IDE mode (yeah, they call it IDE mode when there's no IDE/PATA connector); it also didn't like my optical drive in the first SATA port in AHCI mode.
m
0
l
!