Sign in with
Sign up | Sign in
Your question

Windows 7 SSD AHCI mode - HELP!

Last response: in Storage
Share
February 9, 2013 5:44:25 PM

Hello everyone, this is my first post on the forum.
I searched for this problem but could not find an answer, so hopefully you can help me.

I have an Asus m3n78-vm motherboard and had 500GB hard drive installed, which worked fine with Windows 7.
No I purchased a Corsair Nova 2 CSSD-V60GB2 to install OS on it and have the 500GB hard drive for all other stuff.
I knew this drive had problems with firmware, so I upgraded it to custom firmware from mydigitalssd (mydigitaldiscount website). Basically this SSD has Phison S5 controller, and they develop firmwares which work on Nova 2 as well, which apparently is much better than the stock one.
Anyway, I installed latest firmware and went through to install Windows 7.
I changed bios settings to AHCI. (this is my first install of OS on SSD).
Everything went smooth, but the drive showed up as SATA in Device manager instead of AHCI.
Anyways, I read then somewhere that I had to manually install Asus AHCI drivers in the beginning of Windows install. So I downloaded AHCI drivers (latest) from Asus website and installed them manually during the second install of Windows 7. Again, when the install was over, device manager was not showing the disk as AHCI, so I manually installed Asus AHCI drivers, this time within Windows.
Now it shows me a yellow sign on the "Nvidia nForce Serial Ata controller", although OS works well, it still seems to be slower than the standard (non SSD) hard drive.
I did a benchmark, and the overall score was 156 (not sure what that means though), but I compared it to other Sata2 results and they were much faster than mine.
I also did all the tweaks for SSD within Windows 7.
Any suggestions how to enable AHCI mode on my MB and how to make SSD run faster?
Thanks

More about : windows ssd ahci mode

February 9, 2013 11:09:32 PM

Yes, that's right.
I installed AHCI drivers during a fresh Windows 7 install. After install the drivers were still not displayed as AHCI, so I installed them manually again, but this time already on installed Windows, within device manager.
but now it shows yellow sign. Apparently Windows does not like Asus AHCI drivers and prefers it's own.
So I am interested what steps shall I take to make SDD work on AHCI.

(I know the MB is old and I should change it, but It's enough for the HTPC which I am using it for)
m
0
l
February 11, 2013 10:18:15 AM

78 views by far but no answers...
any ideas anyone?
m
0
l
!