Sign in with
Sign up | Sign in
Your question

Crossfire help

Last response: in Graphics & Displays
Share
September 11, 2010 6:17:01 PM

Hi guys

I installed a second 4890 graphics card and installed everything and enable crossfire but in the ATI control centre's dropdown boxes it only shows one card (whereas it should show both???). Previously when I did crossfire it showed both cards for instance in the overclocking option you could use the dropdown box to choose which card you want to change settings etc. I know this because the first time i installed the drivers it did gave me that option but my power supply couldnt support both so I had to change that and I did....

In devce manager it shows both cards etc, but also in games it makes zero difference........

Core i7 2.8ghz
1000 Watt power supply (82% effeicency)
2 x 4890 radeon cards
P7p55d pro motherboard

Please help


More about : crossfire

a b ) Power supply
a c 169 U Graphics card
September 12, 2010 7:16:42 AM

Hello
So you don't have the "Crossfire tab" in Catalyst control center ? If you don't,then try re-installing the drivers.
a c 216 U Graphics card
September 12, 2010 7:23:06 AM

And if installing the new drivers doesn't make it shown, one or both cards might not be seated well. Try physically removing and reinstalling them to correct, if that's the case.
Related resources
September 12, 2010 7:44:30 AM

I have enabled the crosfire box. And device manager picks up both cards.
a b ) Power supply
a c 169 U Graphics card
September 12, 2010 8:49:16 AM

OK,so your FPS are still low ?
September 12, 2010 9:31:54 AM

Yes

Should I run a benchmark program?
September 12, 2010 9:32:38 AM

Yes still exactly the same.... Not that it was that bad in the first place. I just figured that it would atleast be a bit better?
September 12, 2010 10:27:48 AM

Well if I disable crossfire and plug a second screen into the other card then both work, so both cards work. However why does the FPS stay the same? Should I change profiles etc in the CCC?

Or what can I change there? The TEMP at idle speed is 61 degrees. Is this ok?
a b ) Power supply
a c 169 U Graphics card
September 12, 2010 11:17:53 AM

Open CCC>3D>AI and make sure "Disable Catalyst AI" is unchecked.
Also can you post a benchmark of a game you play ?
September 12, 2010 11:29:07 AM

OK.

ARMA II

Under single player missions there are two benchmarking options.

1. - 37
2. - 16

September 12, 2010 11:29:54 AM

Oh and the AI thingy was unchecked
a b ) Power supply
a c 169 U Graphics card
September 12, 2010 2:09:05 PM

Well first of all ARMA II is a poorly optimized game;however, assuming that the first one is with CF and the second one is with one card,the scores are normal.
September 12, 2010 4:42:05 PM

No, both are with crossfire and both are the same with one card as well -- Also see my Just Cause benchmarks
a c 216 U Graphics card
September 13, 2010 12:17:28 AM

If you performed the benchmarks in windowed mode, the cards will not use crossfire. Also note that not all games support CF (Warhammer 40,000: Dawn of War 2 doesn't for example).
!