Sign in with
Sign up | Sign in
Your question

Mobo swap, No Ethernet Controller!

Last response: in Motherboards
Share
September 26, 2011 2:24:27 PM

I just replaced my motherboard with a P5Q Pro Turbo and installed windows 7. Once in my desktop I plugged in my ethernet cable. Unfortunately, it didn't detect the cable, and the indicator lights on the ethernet port are dark. I then went into device manager and found no ethernet device tab or network adapter tab present. I did how ever find my attention directed to a “unknow device” under other devices. This “unknown device’s” is listed as location: Intel ICH10R LPC Interface 3A16, with a status note reading “Drivers for this device are not installed. (code 28)” under properties, not other usefully information was present.

Just a few notes before I go on. I bought this costum PC form a friend about 18 months ago and it has worked fine other wise. It came with a genuine copy of windows but I don’t have a repair or support disc (don’t know if he lost them or what?) My new P5Q Pro Turbo mobo was bought OME (so possibly refurbished) so I don’t have any support disc for that either. I did how ever down load a driver package from Asus before making the switch, but when I attempt to install the drivers I get a return ~AR8121/AR8113/AR8114 ethernet controller not found, then the install terminates. So this packet is apparently worthless if you don’t have the ethernet controller. I couldn’t use any of the files manually either from my desktop or during windows install.

After failing to install drivers from Asus I took a hint from other’s who had simular issues here, restarted and went in to bios to see if my lan was enabled. Atheros GigaBit Lan was enabled, not sure what a LAN Boot ROM is but I enabled that for experimentation to. Nothing changed.

That is were I stand now. My next guess would be to find a Atheros Lan drive and instal manually but Ill continue researching the issues first and Ill update this if I do any thing.

Mobo – P5Q Pro Turbo
CPU – core2extreme x4
Graphics card – N8800 GTX (640k mem)
Ram – 2x1G Corsair Dominator
PSU – Thermaltake (1200watts)
HDD – 300kb raptor ???
CPU fan – Zelman? Looks like a Jet engine made of copper fins

Those are the specs as I know them off hand. I can more details if need be, but FYI im not very knowledgeable about computer’s hardware or software this all a learning process to me that will hopefully pan out well so I can do my 1st build on the I5 sandybridge down the road.
September 26, 2011 3:56:05 PM

Emerald, I thought of that at one point aop and then forgot about it complete ^.^

Not that Im to cheap to buy one but Id really like to fix this with some kind of software or settings adjustment so that Im not waiting for a part to ship to me. Maybe a local best buy will provide a solution.
m
0
l
Related resources
September 26, 2011 9:26:23 PM

Im concerned now that the missing intergraded Atheros ethernet controller will make for more issues if I dont get it it fixed. I wasnt able to install a driver for my sound card and so Im thinking the same thing will happen if I get a network card.

I call Asus support and after a long run around with a couple lvl 1 techs I got a hold of a lvl 2 who seemed knowledgeable but after 20mins with him there system went down. My line went on hold and operate told me theyd call me back.

I took a poke at flashing my bios, no change.

:sweat: 
m
0
l
September 30, 2011 12:28:10 PM

Ok I broke down and bought the lan card, Good as solved
m
0
l
!