Sign in with
Sign up | Sign in
Your question
Closed

New monitor, horrible textures.

Tags:
  • Graphics Cards
  • Monitors
  • Graphics
Last response: in Graphics & Displays
Share
September 12, 2010 12:12:02 AM

Today I got a new monitor (Acer x213h) and I've been having a couple problems with it. The old one was 19" with a native res of 1440x900. The new one is 21.5" and has a native res of 1920x1080. The main problem is whenever I run a game the textures are HORRIBLY blurred. I tried mass effect 2, dragon age, assassins creed 2, and fallout 3. they all have significantly uglier textures now (apart from assassins creed which seems to look the same). Is this normal and I should deal with it, or is there something I can fix, because this is pretty annoying. Sorry if this sounds like an extreme noob moment. Also, in case you want to know, I'm using an ATI 5770 video card.

More about : monitor horrible textures

a c 153 U Graphics card
a b C Monitor
September 12, 2010 12:38:14 AM

That isn't very normal at all. Did you change the resolutions in game? Most games won't pick up a new monitor resolution, you have to change them yourself...
Score
0
September 12, 2010 12:42:29 AM

Ya, first thing I did in any of them is set the res to 1920x1080.
Score
0
Related resources
a c 153 U Graphics card
a b C Monitor
September 12, 2010 12:46:35 AM

Are they blurred when you take a screen shot of the game? How about you either take a screen shot, or upload a small fraps vid to youtube so we can see.
Score
0
September 12, 2010 12:57:17 AM

Score
0
a c 173 U Graphics card
a b C Monitor
September 12, 2010 1:00:13 AM

This is why I stay with CRT monitors and the only thing you can do is match the native ress of your monitor ingame.
Score
0
a b U Graphics card
a b C Monitor
September 12, 2010 1:08:28 AM

Just looks like the detail settings were set lower.
Score
0
September 12, 2010 1:13:19 AM

Believe it or not, everything's on max. It's kind of funny too, because when I set the textures to low, it looks exactly the same.
Score
0
a b U Graphics card
a b C Monitor
September 12, 2010 1:21:11 AM

According to that Dragon Age screenshot, my only guess is that the settings are set to low. Have you tried resetting the settings again anyway? It's possible that they were automatically changed to low settings by the game but still display as high/max on the options screen.

Oh, and how about reinstalling drivers? Long shot, but worth the try.
Score
0
September 12, 2010 1:54:29 AM

Already tried resetting the textures, including mix of setting the textures, and resetting the game, and rebooting the computer. I also just tried reinstalling the drivers. I was also messing with the settings of cod waw (Its getting the same low texture treatment) and tried reinstalling the whole thing, and that didn't fix it. So I doubt that would work for dragon age or any other game.
Score
0
a b U Graphics card
September 12, 2010 2:09:28 AM

This is most unusual. There is no reason this should be happening.

A few Qs:

1. Latest drivers?

2. Tried re-installing one of the problematic games and see?

3. Temps?

4. Download FurMark/Krombuster and see how the temps,etc and see if you get any artifacts. DL: http://www.ozone3d.net/benchmarks/fur/
Score
0
September 12, 2010 2:21:14 AM

I do have all the latest drivers, I tried reinstalling WaW and nothing changed, I'm not sure what you mean by temps, and nothing out of the ordinary happened with furmark. But yeah, I agree that this is really weird.
Score
0
a b U Graphics card
September 12, 2010 2:46:10 AM

If you go back to your old monitor, does it seem to fix?
Score
0
a b U Graphics card
September 12, 2010 4:12:54 PM

Ivan913 said:
I do have all the latest drivers, I tried reinstalling WaW and nothing changed, I'm not sure what you mean by temps, and nothing out of the ordinary happened with furmark. But yeah, I agree that this is really weird.

Temps as in GPU temps. You can use GPUZ to measure it.

EXT64 said:
If you go back to your old monitor, does it seem to fix?

+1. Also, is there another LCD (including a TV with HDMI/DVI) you can try?
Score
0
September 13, 2010 12:39:17 AM

On furmark the min temp is 51 C and the max after running it for 5 minutes is 66 C. So that seems fine. And I haven't been able to try putting my old LCD on it. When I get a hold of it I will, but is there any other solution anyone can offer me pertaining this until I can try the old LCD?
Score
0
September 13, 2010 11:32:31 PM

Sorry for the double post, but I have a possible solution. I just need help with it. After looking up how to properly install the monitor, most sources say to turn of the computer and monitor before installing it. I skipped that phase and basically just switched it out when i got it, so I'm trying to put the old one back in, get it going, delete the new monitors driver software, re install it, turn off the computer, put on the old monitor, start it again, and hope it works. Only hitch is that whenever I put on the old monitor, it runs for a second, and then goes to black screen, while the power light stays green as if its receiving some input. Anyone know how to fix this? BUt yeah, please reply, this topic is a couple days old, but I REALLY need the help, thanks. :) 
Score
0

Best solution

a b U Graphics card
September 13, 2010 11:45:48 PM

One thing I've noticed with my 5770 is that some games auto detect it as an OLD Nvidia FX57xx series card which is an older Nvidia card that had problems with the shader model implementation and some games had special settings for that so some games (Oblivion for one) will autoset to VERY LOW and turn off some of the shaders and you have to reset them or live with the Ultra low settings (just changing the resolution still leaves the shaders and other settings messed up so you have to manually fix the ini settings to enable the shaders. ) In Oblivion using the Launcher and resetting the preset buttons to set Ultra High fixes the problem. (looks to be the same sort of problem from your screenie !)


EDIT : As far as the problem going back to the old monitor -- If you already switched to the new monitor and reset to the higher resolution plugging the olkd monitor in without resetting back to the lower resolution will have the old monitor not work since it can not display that larger resolution -- you need to first go back to the lower resolution before going back to the old monitor !! (but the monitor is most likely not the problem so no real need to do that anyway !) -- best option would be to boot into safe mode - this will load the generic VGA driver - then reinstall the new drivers for the video card and ( new .inf file for the monitor if you have one). then check the config files for the game and ensure they are not disabling the various shaders and adjust them if needed.
Share
a b U Graphics card
September 14, 2010 1:35:05 AM

Quote:
One thing I've noticed with my 5770 is that some games auto detect it as an OLD Nvidia FX57xx series card which is an older Nvidia card that had problems with the shader model implementation and some games had special settings for that so some games (Oblivion for one) will autoset to VERY LOW and turn off some of the shaders and you have to reset them or live with the Ultra low settings (just changing the resolution still leaves the shaders and other settings messed up so you have to manually fix the ini settings to enable the shaders. ) In Oblivion using the Launcher and resetting the preset buttons to set Ultra High fixes the problem. (looks to be the same sort of problem from your screenie !)

Huh. Never knew that.
Score
0
September 14, 2010 9:59:09 PM

JDFan, would you mind telling me how to install the drivers in safe mode, because the ati installer doesnt wanna work in safe mode, and I can't find my monitor from the device manager while in safe mode either. Otherwise, thanks for giving me a possible solution. It's odd that my video card would start doing this at the same time that I get a new monitor.
Score
0
a c 124 U Graphics card
a b C Monitor
September 14, 2010 10:08:10 PM

You can't run an installer in Safe Mode. What you can do is boot normally and uninstall your ATI and monitor drivers, also if there's any Nvidia drivers uninstall them. Then you can reboot into Safe Mode and run Driver Sweeper to find and delete any last traces of the drivers. Running a registry cleaner like Ccleaner would also be a good idea at this point. Then reboot and reinstall ATI drivers + monitor drivers.
Score
0
September 15, 2010 12:31:52 AM

Best answer selected by Ivan913.
Score
0
September 15, 2010 12:32:53 AM

Thanks for the help everyone :D , particularly JDFan for finding the problem, but also wolfram for showing me how to fix it.
Score
0
a c 274 U Graphics card
a b C Monitor
September 15, 2010 3:05:13 AM

This topic has been closed by Mousemonkey
Score
0
!