Sign in with
Sign up | Sign in
Your question
Closed

ATI Radeon HD 5800 SC2 Lag!

Last response: in Graphics & Displays
Share
September 12, 2010 4:46:38 AM

I have a Intel Core i5 650 @ 3.20 GHz and ATI Radeon HD 5800 Series. And whenever i play Starcraft 2 i lag on anything above Low, every other game i can run like a champ but i seriously don't know what to do. Anyone know?
September 12, 2010 6:59:59 AM

What resolution do you play at ? how's your FPS in other games ?
Also make sure you have the latest VGA drivers installed.
Score
0
September 12, 2010 7:27:53 AM

Maziar said:
What resolution do you play at ? how's your FPS in other games ?
Also make sure you have the latest VGA drivers installed.

Im forced to play on Low/Medium while i know i can play ultra easily. I get 35 fps on League of Legends and I think 30 on Team fortress all Very High. And recently i just tried downloading the recent VGA drivers and it messed up my Resolution taking forever to fix it
Score
0
Related resources
September 12, 2010 7:33:04 AM

I'd recommend you use driversweeper from Guru3d and clear out all your video drivers then install a fresh lot of updated ones(I think there 258??)

Then try all your games again and get back to us.
Score
0
September 12, 2010 7:40:28 AM

decode said:
I'd recommend you use driversweeper from Guru3d and clear out all your video drivers then install a fresh lot of updated ones(I think there 258??)

Then try all your games again and get back to us.

Can i get a link the the driver i need to download? please and ty
Score
0
September 12, 2010 7:48:06 AM

is it 5850 or 5870. try all the games in all types of settings and post the scores. and if you can try testing it with reduced anti aliasing but others at decent levels
Score
0
September 12, 2010 7:50:47 AM

dragon5677 said:
is it 5850 or 5870. try all the games in all types of settings and post the scores. and if you can try testing it with reduced anti aliasing but others at decent levels

It just says 5800 and im really not good with computers, i just uninstalled the driver and resinstalled and my computer resolution is bad =/
Score
0
September 14, 2010 1:47:35 PM

Please help,


For the most part, the game runs the same on either low or ultra in terms of FPS. However, in any 3v3 or 4v4 game (or any epic battles) they game starts seizing up. Originally, I just had 4gb so I bought 4 more yesterday and I don't notice it making any improvements. I played l4d2 w/ 4 gigs and the game flew. However, it just can't take the big battles. Worst off, it always ends up hitting like a truck. Once I'm in a game for more than 20 minutes, there are usually enough units to start drastically slowing down the gameplay to the point that it just isn't fund anymore. If anyone has any suggestions, I would really appreciate it. You can see my specs below

Specs:

XFX HD-487A-ZHFC Radeon HD 4870 1GB 256-bit GDDR5
G.SKILL 4GB (2 x 2GB) 240-Pin DDR2 SDRAM DDR2 1066 (PC2 8500)
OCZ Platinum 4GB (2 x 2GB) 240-Pin DDR2 SDRAM DDR2 1066 (PC2 8500)
AMD Phenom II X4 940 Black Edition Deneb 3.0GHz Socket AM2+ 125W Quad-Core Processor HDZ940XCGIBOX
GIGABYTE GA-MA790GP-UD4H AM3/AM2+/AM2 AMD 790GX HDMI ATX AMD Motherboard
Score
0
September 14, 2010 7:39:49 PM

@lakersfan1

Send your 58xx for repairs seems like you might have some bad vram or bad memory on the card you should easily get 70+fps on team fortress 2 at max settings with a 58xx card of course. Since you haven't stated your full computer specs it's kinda hard to tell you what is wrong it could also be your PSU is not powerful enough for your current set up.

@overbeee

From what you describe it may be your card is getting to hot over time and your GPU throttles its self to stop it from getting to hot.
Score
0
September 15, 2010 1:51:23 PM

I should add:

The cinematics don't run properly either. They're choppy (both video and audio) as hell.
Score
0
September 15, 2010 5:48:46 PM

@lakersfan1

If your resolution is bad, change it in CCC to your monitors proper setting. This can happen after reinstalling drivers.
You didn't indicate if the new drivers made any performance diff.
You never did answer the resolution question. What size monitor?

@overbee

I see you have a mobo with onboard video and a 4870 card. Are you running in hybrid crossfire, or just off of the 4870? I would make sure the onboard video is disabled with a card like the 4870.
Score
0
September 15, 2010 6:18:42 PM

I'm not sure that I have disabled the onboard video... Do you mind running me through how to do that? I'm a noob.

Thanks,

Brian
Score
0
September 15, 2010 7:11:42 PM

Enter the BIOS during boot by pressing delete
I'm not familiar with that particual BIOS, but there should be an option to initialize pci-ex first, which should (from what little reading I've done on your board) use the 4870 only.

You can always check by looking at the Information in the CCC or by looking at "display adaptors" in the Windows device manager to see if one or both are enabled.
Score
0
September 20, 2010 11:05:17 PM

Card name: ATI Radeon HD 5800 Series
Memory: 4096MB RAM
Processor: Intel(R) Core(TM) i5 CPU 650 @ 3.20GHz (4 CPUs), ~3.2GHz
Operating System: Windows 7 Ultimate 64-bit
Motherboard: BIOSTAR TH55B HD
Display Memory: 2770 MB
Score
0
September 21, 2010 12:39:22 AM

I have my video card drivers up to date i got Ver. 10.8
Score
0
September 21, 2010 1:15:10 AM

^Well unless you are sure you did a clean install I would run drivers sweeper and reinstall just for the hell of it to rule that out as the problem.
Score
0
September 21, 2010 2:56:44 AM

benski said:
^Well unless you are sure you did a clean install I would run drivers sweeper and reinstall just for the hell of it to rule that out as the problem.

Just did it, nothing
Score
0
September 21, 2010 2:45:41 PM

Damn I dunno man, maybe you need to reinstall the game or something if everything else runs fine. It's not really a demanding game you should be able to max everything out with no problem.
Score
0
September 22, 2010 6:43:59 AM

Anyone else got any ideas?
Score
0
September 22, 2010 7:09:04 AM

Reinstall the game since you say everything else runs fine except for sc.
Score
0
September 22, 2010 1:24:01 PM

I've read a few posts on the 'net about the 5970 having poor performance in SC2. It seems it doesn't respond well with Crossfire, and for users that have 2 cards disabling Crossfire in the CCC allows the game to run much better.

Also, I've read that updated BIOS can sometimes fix issues if you have lock up issues.

Try upgrading to version 10.9 of your drivers.

Under the section "Resolved Issues for the Windows 7 Operating System":

CrossFireTM now functions properly and in-game Anti-Aliasing can now be enabled in "StarCraft II"
Score
0
September 26, 2010 5:57:05 AM

I just fixed it, my processor wasn't fully locked in and i guess it caused it to overheat. Thanks for all the help guys
Score
0
September 26, 2010 5:58:03 AM

This topic has been closed by Mousemonkey
Score
0
!