Sign in with
Sign up | Sign in
Your question

IOmega UltraMax 1TB strangely failing

Last response: in Storage
Share
February 13, 2013 1:56:51 PM

Hi Guys! :hello: 

I'm hoping your bright minds will know how to solve my strange, recurring problem.

I purchased mentioned iOmega UltraMax 1TB a couple years ago. At first I used to have it on at all times, storing most of my data on it.
Then, within the warranty period, I started having problems with it - it would basically "hang"/freeze. No system eject would work, so I'd switch it off, and on again and it would work. Unfortunately, only for a while.

It's operational time would get shorter and shorter, until it was clear that there's smth wrong with it. So, I sent it back for warranty. After keeping it for ridiculous 2 months period, they'd send it back saying it's not a faulty unit.

So I pack it up with data again (not even to half it's capacity), and after only a week or so it started hanging again:(  Needless to say I didn't want to send it back to the company, so I asked around and a couple people would look at it. No one knew what the problem is.

I'd test the drive on other computers, and just like on mine, it wouldn't show up in the system.

Quite a while has passed, my computer's (imac g5 isight with snow leopard on) power unit has burned, so I replaced it myself with new one. After that, just out of desperate need, I hooked the drive in again, and... it worked! :wahoo: 

I tested it for a while (~0.5h) and everything seemed fine - all data on it, fully readable. So I happily assumed this previous problem occurred due to that faulty power unit.

Unfortunately my jolly mood didn't last too long. The drive started freezing Finder.app yet again, usually during reading/copying data, but also while idle.
Then I'd try to restart Finder, but it would come up with -10810 error saying Finder can't be opened, until I switch the drive off.
Now again it stopped showing up on the system. :pfff: 

Some say that the drive is totally buggered, but I don't believe it. Even when it's "freezed", one can hear that it crunches on some data every minute or so. Also when starting it sounds perfectly fine... I tried usb and FireWire, but none would make any difference.

Let me know if I can provide additional data for You to help understand this better.
Thanks in advance for your advice!

More about : iomega ultramax 1tb strangely failing

a b G Storage
February 13, 2013 2:17:41 PM

We had a iomega 4x2tb nas unit at work. Ran for about a year till one drive failed. Was no big deal, called the company and they sent a replacement drive. Put it in and rebuilt the array. Not more then 6 months later another drive failed, went through the same deal, drive sent rebuild array. Two months later the unit just stop seeing the drives all together.

If it was me I'd move away from it asap.
February 13, 2013 2:49:27 PM

Hi faalin,
Thanks for your response.

Yes, I'm willing to do that, but first I need to retrieve the data from it - I'm a photographer and designer, and it carries most of my portfolio on it... You understand how crucial it is for me...

I'm planning on reinstalling my system, hoping that it's a software issue.
Also, today a friend suggested that I should try hooking it up to Linux based computer, as it is also UNIX system. The drive is formatted in mac journal, so I dunno if that could work, but I'll try anything.
February 17, 2013 2:17:09 AM

There we go. The drive works perfectly well with that sata adapter. Thanks to spunk.funk for his tip! He helped me solve a problem that iOmega's service didn't not only fix, but even detect during 2 months long check up...
!