Memory running at low speed

I recently installed 2x 4gb modules of Corsair Vengeance. I think these are supposed to run at 1600MHz, but they're running at 1333MHz. This is probably because my old ram modules were 1333Mhz so the motherboard is using the same settings. I went into my BIOS and tried to change the memory timings to 1600MHz but when i did the computer no longer boots up. I had to restore it to previous settings to get it to work at all.

My motherboard is a Foxconn Inferno Katana, my CPU is an i7-860. No overclocking.

Is it beneficial to get my ram modules running at 1600MHz? If so, how do i do it?

Thanks in advance! :)
5 answers Last reply
More about memory running speed
  1. go into the BIOS and look for the memory timings... you should be able to tell it that the RAM is 1600 timing. Check the full spec and manually input it if needed.
  2. You will get about a 1% performance increase if you increase the speed.

    Also, the MB is only designed to run RAM up to 1333MHz without overclocking.

    You will have to manually overclock the RAM to get it running at 1600MHz, which will cause stability issues, and give you almost no performance bonus.
  3. Well the BIOS has an option to change it to 1600, it just won't boot when i use it. If it's such a small performance gain i'll just leave it as it is then, thanks!
  4. I know when I tried to get my 1600MHz RAM to work (from 1333) I had to change the command rate to 2. Try seeing if you have a setting in there for that. It might be a simple fix.
  5. Hmm...IF we're going to post then it is Helpful to tell you.

    ref - http://www.foxconnchannel.com/product/Motherboards/detail_spec.aspx?ID=en-us0000476

    Your CPU, i7-860, is faster than 2.66GHz so it can handle DDR3-1600 with not much if any problems.

    BIOS:
    Memory Bus Frequency Mode -> (16 or DDR3-1600MHz)
    Memory Remap Feature -> Enabled

    Options:
    DRAM Command Rate -> 2 (same as 2T or 2N)
    Configure DRAM Timing by SPD -> Auto ; if CPU-z CAS Timings are wrong per Corsair spec change
    DRAM Voltage Setting -> Auto ; IF RAM is 1.65v at Rated -> 1.65v or closet menu value
    CPU VTT -> Auto ; problems use 1.20 (1.50v RAM) or 1.30v (1.65v RAM)
Ask a new question

Read More

Memory Motherboards