Sign in with
Sign up | Sign in
Your question

Graphics driver installation

Last response: in Graphics & Displays
Share
September 14, 2010 4:29:37 AM

im installing older ati drivers for use with a particular game, i followed this process to install my current driver which are the latest ones.

1 deleted ati software from add remove programs

2 booted in safe mode

3 used driver cleaner

4 booted in normal boot

5 used ccleaner

this worked for me when i installed the new drivers, but now when im booting into normal mode (step 4) windows 7 stays at the black loading screen before the desktop is shown. i can hear the sound you would hear when windows is installing the standard vga drivers but the desktop is never shown.

i tried just uninstalling the driver from device manager but the driver isn't installed after your finished the installation process.
September 14, 2010 5:08:10 AM

ok what? i cant follow which drivers aren't working. the New new ones, or the new old ones? can you use the driver versions instead of "old drivers" and "new drivers"?
September 14, 2010 5:12:41 AM

currently installed drivers are catalyst 10.8, i want to install version 10.6.
i want to install older ati drivers (10.6) for use with a particular game, i followed this process to install my current driver which are the latest ones (10.8).

1 deleted ati software from add remove programs

2 booted in safe mode

3 used driver cleaner

4 booted in normal boot

5 used ccleaner

this worked for me when i installed the new drivers (10.8), but now when im booting into normal mode after uninstalling the 10.8 drivers (step 4) windows 7 stays at the black loading screen before the desktop is shown. i can hear the sound you would hear when windows is installing the standard vga drivers but the desktop is never shown.

i tried just uninstalling the driver (10.8) from device manager but the driver isn't installed after your finished the installation process.

i cant get onto desktop after uninstalling the 10.8 drivers.
Related resources
September 14, 2010 5:30:28 AM

So right now you have no drivers installed, and you have no boot, correct? can you get back into safe mode? maybe your driver cleaner missed something? What card do you have?
September 14, 2010 5:48:14 AM

i think you had a bad install somewhere. And theres a bit of driver left somewhere Which is why 10.8 doesn't show up right. FWIW, I couldn't get 10.8 to install on my comp today. It kept installing with errors. After much finagling, rebooting, and driver sweeping, i got 10.7 installed.
September 14, 2010 6:00:58 AM

i restored to get back to a previous state just before i uninstalled the 10.8 drivers. its a hd 4870 card.

how would you go about installing older drivers if you needed to?

September 14, 2010 6:15:11 AM

its like installing new drivers, you just use the older package. heres what i suggest
redownload whatever driver package you want to install
Uninstall 10.8
do not reboot
in the search box in the task menu, run msconfig
in the boot tab, check safe mode
apply, then ok
then reboot.
you probably already know how to do this. but just as well...
run driver cleaner
redo the msconfig
uncheck safe mode box
reboot.

September 14, 2010 6:17:02 AM

you have probably done this a million times i know, but im trying to make sure we are on the same page.
September 14, 2010 6:39:44 AM

yeah thats what i was doing... its just that i cant get back to the desktop after rebooting at the end. thanks i was just making sure. i can hear the standard drivers being installed and stuff but no picture other than the black screen with the logo.
September 14, 2010 6:42:07 AM

after you run the driver sweeper, dont uncheck "boot in safe mode"
can you then reboot into safe mode again?
September 14, 2010 7:14:27 AM

im gonna have to call a shenanigans and say faulty card, because I went through the same problems with my faulty xfx 5750. I had it somewhat stable on 10.3, tried 10.4, and spent several months dealing with system restores, no booting past windows loading screen, full windows reinstalls, and different drivers. I replaced my xfx with an asus, and all my problems stopped. immediately.
September 14, 2010 10:41:57 AM

damn i hope its not, any ideas about how i can resolve this? i cant change my driver at all. anyone??
a b \ Driver
September 14, 2010 3:13:49 PM

Add/remove Programs ATI uninstall everything
Download and install Driversweeper
Run Driversweeper in safemode
Check off ATI
Click purge
Start normal
re-install the last stable version of CCC as Administrator
!