PC Won't POST anymore

Hi guys. Recently a friend brought over his PC to have me format it. Since I had no spare cables (VGA, power, keyboard, mouse), I decided to take the cables off my other desktop and plug in my friend's PC so I can work on it.

The problem is, when I reconnected my desktop, it just wouldn't POST anymore :(
I followed all the steps in this thread:
http://www.tomshardware.co.uk/forum/261145-13-perform-steps-posting-boot-video-problems

I even completely took out the parts (except CPU) and then placed them back again (like completely building a new rig) and still no POST. The motherboard light is on so PSU works. I also placed another working PSU to be sure and it's still not POST-ing.

When I press the power button, the CPU fan turns on, the green LED light turns on, the HDD red LED turns on, but no POST.

This are the specs:
Pentium 4 1.70 GHz
Asus P4S533-E
ATI Radeon 9250 128 MB
1 GB DDR RAM
40 GB WDC HDD
Generic 550W PSU

It's a really old PC, I know. But it was working perfectly fine before I took it out, and it isn't subjected to hard use since it's just a spare PC (good for youtube and using my old scanner that only works on XP).

Is there anything else I could do to get this working? I really doubt that the MB has just given up.
1 answer Last reply
More about post anymore
  1. Do you have a PC Speaker in there? If so, any beeps?

    Might be a video card thing as well...
Ask a new question

Read More

Homebuilt Systems