Sign in with
Sign up | Sign in
Your question

Can't get SLI to work on GTX 470

Last response: in Graphics & Displays
Share
September 15, 2010 8:36:07 PM

Hi guys!

So i got my new system and it works very well, except for my second grafic card. I cannot get it into SLI.

Heres what i did to try to make it work:

1. Swapped the 2 cards, to see if i get the enable SLI option in windows. Nothing!
2. Checked BIOS if there was anything i needed to activate. I know on my old mobo i had an option there to turn on/off. But i could actually not find any SLI options there - so i guess its on wether you want it or not? =)
3. Reinstalled 258.96 drivers and rebooted. Allso tried 257.21 drivers and rebooted.
4. PhysX is installed and activated on one of my cards.
5. Have no issues what so ever in device manager. Both cards show up.
6. I have looked through various forums and SLI options to activate SLI in Nvidia control panel.
7. I tried 2 SLI bridges.
8. All four Pci-e connectors are connected to my cards.
9. I have set it to Advanced settings in nvidia control panel.
10. I have not overclocked anything

Oh and when i reboot my comp i have never seen the "enable SLI option" pop up after inserting the new card. I never had any hangups or Bsods.

My setup is: Mobo P55-GD65. Intel i5 2.80ghz. 4GB ram. Corsair SSD HD.

Thanks for your replies! :p 

More about : sli work gtx 470

September 15, 2010 9:03:53 PM

Oh and one more thing... do any of you guys know of any program wich can tell if you actually have SLI activated or not? Because i cannot see the option anywhere. I'm guessing i dont have it activated, but would be great to use a program to doublecheck it.
a c 273 U Graphics card
September 15, 2010 9:10:40 PM

Try 3D'06 with the SLi indicators enabled, of course if you can't set the system into SLi mode because you don't have the option in the Nvidia control panel then then you have a problem with something else.
Related resources
a b U Graphics card
September 15, 2010 9:18:12 PM

Try the new 260.63 drivers
gpu-z has a sli indicator on its front tab.
a c 273 U Graphics card
September 15, 2010 9:19:44 PM

notty22 said:
Try the new 260.63 drivers
gpu-z has a sli indicator on its front tab.

Doh! I forgot about that. :lol: 
a b U Graphics card
September 15, 2010 9:37:22 PM

I had this problem after installing Dark Void, I got driver sweeper from here and installed ( http://downloads.guru3d.com/Guru3D---Driver-Sweeper-(Setup)_d1655.html) I had to uninstall the driver and all related nvidia files and programs, restart into safe mode run driver sweeper and look for nividia files only, remove anything related to nvidia and restart normaly reinstall your drivers and see if that fixes it.
September 16, 2010 8:28:42 AM

Thx for your replies guys! I tried the driver sweeper and got rid of all the nvidia files, i even looked at my C:\ for more of them. Couldnt find any and when i booted up it didnt install any Nvida files at all so it must have worked?

I tried to reboot in between, still no "enable SLI" settings to be found. Still this problem i have feels like a software problem doesnt it? Theres nothing physicaly wrong with my cards. Atleast i think so.
Notty and mousemonkey: i'll dl the 260.63 drivers and see if that fixes the problem. I didnt even know there was newer driver out there. Apart from doing that i'm all out of ideas.... or maybe i shall install even older variants of nvidia drivers?
September 16, 2010 10:13:18 AM

I have now updated my BIOS. I have allso connected my other SLI bridge, but not at the same time. Silly question: shall i connect both SLI bridges on the cards? I guess not but i need to ask. My system detects both cards without a problem.

I tried several times to get rid of the nvidia files by using the driver cleaner and it worked just fine.

I tried the 260.63 drivers (both 64-bits and 32-bits) but it says my Windows doesnt support them. I have windows 7 Ultimate N (don't know what the N stands for though)
September 16, 2010 11:00:20 AM

I rolled back my network drivers and it WORKED! I got a tip from a guy who got it to work this way. I never thought it would work for me but it did!
October 5, 2011 7:45:44 PM

how do you roll back network drivers?
June 6, 2014 12:09:21 AM

yes, how
!